summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-03-27 16:17:50 -0400
committerMatt Turner <mattst88@gentoo.org>2021-03-27 16:40:19 -0400
commit178922b056cd1f5b98689dbe7e94fb55d5985a6f (patch)
tree1a92339e352340d5dbde7b72dab7c383a7ceb21a /games-puzzle/gnome-klotski
parentgames-puzzle/gnome-klotski: Version bump to 3.38.2 (diff)
downloadgentoo-178922b056cd1f5b98689dbe7e94fb55d5985a6f.tar.gz
gentoo-178922b056cd1f5b98689dbe7e94fb55d5985a6f.tar.bz2
gentoo-178922b056cd1f5b98689dbe7e94fb55d5985a6f.zip
games-puzzle/gnome-klotski: Version bump to 3.38.2
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'games-puzzle/gnome-klotski')
-rw-r--r--games-puzzle/gnome-klotski/gnome-klotski-3.38.2.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/games-puzzle/gnome-klotski/gnome-klotski-3.38.2.ebuild b/games-puzzle/gnome-klotski/gnome-klotski-3.38.2.ebuild
new file mode 100644
index 000000000000..84a764921058
--- /dev/null
+++ b/games-puzzle/gnome-klotski/gnome-klotski-3.38.2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+VALA_MIN_API_VERSION="0.40"
+
+inherit gnome.org gnome2-utils meson vala xdg
+
+DESCRIPTION="Slide blocks to solve the puzzle"
+HOMEPAGE="https://wiki.gnome.org/Apps/Klotski"
+
+LICENSE="GPL-3+ FDL-1.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-libs/libgee:0.8=
+ >=dev-libs/glib-2.42.0:2
+ >=dev-libs/libgnome-games-support-1.7.1:1=
+ >=x11-libs/gtk+-3.24.0:3
+ >=gnome-base/librsvg-2.32.0:2
+"
+DEPEND="${RDEPEND}
+ gnome-base/librsvg:2[vala]
+"
+BDEPEND="
+ $(vala_depend)
+ dev-libs/appstream-glib
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ xdg_src_prepare
+ vala_src_prepare
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}