summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2018-05-01 14:04:15 +0200
committerPacho Ramos <pacho@gentoo.org>2018-05-01 21:32:56 +0200
commit3f4e6b70c5a63320214b71fa9645bbbaf9560cc5 (patch)
tree04f745b1cf2b7ee9e65ba0f56e442cceb2316285 /games-puzzle/gtkballs
parentgames-puzzle/groundhog: Drop old (diff)
downloadgentoo-3f4e6b70c5a63320214b71fa9645bbbaf9560cc5.tar.gz
gentoo-3f4e6b70c5a63320214b71fa9645bbbaf9560cc5.tar.bz2
gentoo-3f4e6b70c5a63320214b71fa9645bbbaf9560cc5.zip
games-puzzle/gtkballs: Stop using games.eclass
Package-Manager: Portage-2.3.31, Repoman-2.3.9
Diffstat (limited to 'games-puzzle/gtkballs')
-rw-r--r--games-puzzle/gtkballs/gtkballs-3.1.5-r2.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/games-puzzle/gtkballs/gtkballs-3.1.5-r2.ebuild b/games-puzzle/gtkballs/gtkballs-3.1.5-r2.ebuild
new file mode 100644
index 000000000000..eece76f8cc06
--- /dev/null
+++ b/games-puzzle/gtkballs/gtkballs-3.1.5-r2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit desktop
+
+DESCRIPTION="An entertaining game based on the old DOS game lines"
+HOMEPAGE="http://gtkballs.antex.ru/"
+SRC_URI="http://gtkballs.antex.ru/dist/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls"
+
+RDEPEND="
+ x11-libs/gtk+:2
+ nls? ( virtual/libintl )
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ nls? ( >=sys-devel/gettext-0.10.38 )
+"
+
+src_prepare() {
+ default
+ sed -i \
+ -e '/^nlsdir=/s:=.*:=/usr/share/locale:' \
+ -e '/^localedir/s:=.*:=/usr/share/locale:' \
+ configure po/Makefile.in.in || die "sed locale failed"
+}
+
+src_configure() {
+ econf $(use_enable nls)
+}
+
+src_install() {
+ default
+ newicon gnome-gtkballs.png ${PN}.png
+ make_desktop_entry gtkballs "GTK Balls"
+}