summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-05-21 11:48:02 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-05-21 11:48:02 +0200
commit6c0df93ad2c6f43f7e85df94a3ace12a19b04b48 (patch)
tree4a7f35e5495aa98870a583f301a958f2f70ea760 /games-puzzle/hexalate/hexalate-1.1.6.ebuild
parentapp-text/djview: Add missing || die (diff)
downloadgentoo-6c0df93ad2c6f43f7e85df94a3ace12a19b04b48.tar.gz
gentoo-6c0df93ad2c6f43f7e85df94a3ace12a19b04b48.tar.bz2
gentoo-6c0df93ad2c6f43f7e85df94a3ace12a19b04b48.zip
games-puzzle/hexalate: 1.1.6 version bump
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'games-puzzle/hexalate/hexalate-1.1.6.ebuild')
-rw-r--r--games-puzzle/hexalate/hexalate-1.1.6.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/games-puzzle/hexalate/hexalate-1.1.6.ebuild b/games-puzzle/hexalate/hexalate-1.1.6.ebuild
new file mode 100644
index 000000000000..30006721ad40
--- /dev/null
+++ b/games-puzzle/hexalate/hexalate-1.1.6.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit qmake-utils xdg-utils
+
+DESCRIPTION="A color matching game"
+HOMEPAGE="https://gottcode.org/hexalate/"
+SRC_URI="https://gottcode.org/${PN}/${P}-src.tar.bz2"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+BDEPEND="
+ dev-qt/linguist-tools:5
+"
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ eqmake5 PREFIX="/usr"
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}