summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAzamat H. Hackimov <azamat.hackimov@gmail.com>2020-07-07 02:14:08 +0300
committerSam James <sam@gentoo.org>2020-10-08 13:14:53 +0000
commit71226ff0e9abfedcb00d5adfe87fb22bf55f4b46 (patch)
tree4770fe71735ea33cb3f876f0af26b198deb9d647 /games-puzzle/lmarbles
parentkde-frameworks/extra-cmake-modules: 5.74.0 ALLARCHES stable (diff)
downloadgentoo-71226ff0e9abfedcb00d5adfe87fb22bf55f4b46.tar.gz
gentoo-71226ff0e9abfedcb00d5adfe87fb22bf55f4b46.tar.bz2
gentoo-71226ff0e9abfedcb00d5adfe87fb22bf55f4b46.zip
games-puzzle/lmarbles: migrate to EAPI7
Migrated from deprecated eclass. Closes: https://bugs.gentoo.org/731128 Package-Manager: Portage-2.3.99, Repoman-2.3.23 Signed-off-by: Azamat H. Hackimov <azamat.hackimov@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-puzzle/lmarbles')
-rw-r--r--games-puzzle/lmarbles/lmarbles-1.0.8-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/games-puzzle/lmarbles/lmarbles-1.0.8-r1.ebuild b/games-puzzle/lmarbles/lmarbles-1.0.8-r1.ebuild
new file mode 100644
index 000000000000..53b5aa2c7c59
--- /dev/null
+++ b/games-puzzle/lmarbles/lmarbles-1.0.8-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools
+
+DESCRIPTION="puzzle game inspired by Atomix and written in SDL"
+HOMEPAGE="http://lgames.sourceforge.net/LMarbles/"
+SRC_URI="https://download.sourceforge.net/lgames/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="media-libs/libsdl[video]
+ media-libs/sdl-mixer"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+ mv configure.{in,ac}
+ rm *.m4
+ eautoreconf
+}
+
+src_install() {
+ default
+ dodoc src/manual/*
+}