summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-puzzle/skoosh/skoosh-2.5.0-r1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-puzzle/skoosh/skoosh-2.5.0-r1.ebuild')
-rw-r--r--games-puzzle/skoosh/skoosh-2.5.0-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/games-puzzle/skoosh/skoosh-2.5.0-r1.ebuild b/games-puzzle/skoosh/skoosh-2.5.0-r1.ebuild
new file mode 100644
index 000000000000..e207433060d1
--- /dev/null
+++ b/games-puzzle/skoosh/skoosh-2.5.0-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+GCONF_DEBUG="yes"
+
+inherit eutils gnome2
+
+DESCRIPTION="Sliding tile puzzle for Gnome 2"
+HOMEPAGE="http://homepages.ihug.co.nz/~trmusson/programs.html"
+SRC_URI="http://homepages.ihug.co.nz/~trmusson/stuff/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="nls"
+
+RDEPEND="
+ >=gnome-base/gconf-2:2
+ gnome-base/libgnome-keyring
+ >=gnome-base/libgnomeui-2
+ nls? ( virtual/libintl )
+"
+# needs scrollkeeper-preinstall from rarian to build
+DEPEND="${RDEPEND}
+ app-text/rarian
+ nls? ( sys-devel/gettext )
+"
+
+src_prepare() {
+ # Fix .desktop file
+ epatch "${FILESDIR}/${PN}-2.5.0-desktop.patch"
+
+ # Need to apply omf fix or else we get access
+ # violation errors related to sandbox.
+ gnome2_omf_fix "${S}/help/C/Makefile.in"
+
+ gnome2_src_prepare
+}