summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-puzzle/triptych-demo/triptych-demo-0.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-puzzle/triptych-demo/triptych-demo-0.ebuild')
-rw-r--r--games-puzzle/triptych-demo/triptych-demo-0.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/games-puzzle/triptych-demo/triptych-demo-0.ebuild b/games-puzzle/triptych-demo/triptych-demo-0.ebuild
new file mode 100644
index 000000000000..589a67c0974e
--- /dev/null
+++ b/games-puzzle/triptych-demo/triptych-demo-0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils games
+
+DESCRIPTION="fast-paced tetris-like puzzler"
+HOMEPAGE="http://www.chroniclogic.com/triptych.htm"
+SRC_URI="http://s159260531.onlinehome.us/demos/triptych.tar.gz"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="-* x86"
+IUSE=""
+RESTRICT="mirror bindist strip"
+
+DEPEND="x11-libs/libXext
+ media-libs/libsdl[opengl,sound,video]
+ virtual/opengl"
+RDEPEND=${DEPEND}
+
+QA_PREBUILT="${GAMES_PREFIX_OPT}/${PN}/triptych ${GAMES_PREFIX_OPT}/${PN}/setup"
+
+S=${WORKDIR}/triptych
+
+src_install() {
+ local dir=${GAMES_PREFIX_OPT}/${PN}
+ dodir "${dir}"
+
+ cp -pPR * "${D}"/${dir}/ || die
+ games_make_wrapper triptych ./triptych "${dir}"
+
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ # Fix perms on status files #74217
+ local f
+ for f in triptych.{clr,cnt,scr} ; do
+ f="${ROOT}/${GAMES_PREFIX_OPT}/${PN}/${f}"
+ if [[ ! -e ${f} ]] ; then
+ touch "${f}" \
+ && chmod 660 "${f}" \
+ && chown ${GAMES_USER}:${GAMES_GROUP} "${f}" \
+ || die
+ fi
+ done
+}