summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2018-06-17 22:49:51 +0100
committerJames Le Cuirot <chewi@gentoo.org>2018-06-17 22:54:25 +0100
commitd281cb6b05e92b2e651405beec01bcc18bdbd1e2 (patch)
tree8e2d76d2510a1c2427d181731dca800ac3aa21e1 /games-puzzle/triptych/triptych-1.16.ebuild
parentprofiles: Mask 32-bit only games-puzzle/triptych on amd64 no-multilib (diff)
downloadgentoo-d281cb6b05e92b2e651405beec01bcc18bdbd1e2.tar.gz
gentoo-d281cb6b05e92b2e651405beec01bcc18bdbd1e2.tar.bz2
gentoo-d281cb6b05e92b2e651405beec01bcc18bdbd1e2.zip
games-puzzle/triptych: Move from triptych-demo, SRC_URI fix, EAPI 7
The full version and demo version are actually the same. You obtain registration details by ordering online. This is not a version bump. The previous ebuild used the same tarball but had version 0 despite the game reporting 1.16. Closes: https://bugs.gentoo.org/640572 Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'games-puzzle/triptych/triptych-1.16.ebuild')
-rw-r--r--games-puzzle/triptych/triptych-1.16.ebuild63
1 files changed, 63 insertions, 0 deletions
diff --git a/games-puzzle/triptych/triptych-1.16.ebuild b/games-puzzle/triptych/triptych-1.16.ebuild
new file mode 100644
index 000000000000..e2257e17ad3f
--- /dev/null
+++ b/games-puzzle/triptych/triptych-1.16.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop eutils user
+
+DESCRIPTION="Fast-paced Tetris-like puzzler"
+HOMEPAGE="http://www.chroniclogic.com/triptych.htm"
+SRC_URI="http://www.chroniclogic.com/demos/${PN}.tar.gz"
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+RESTRICT="bindist mirror strip"
+
+RDEPEND=">=media-libs/libsdl-1.2[abi_x86_32,opengl,sound,video]
+ virtual/opengl[abi_x86_32]
+ x11-libs/libX11[abi_x86_32]
+ x11-libs/libXext[abi_x86_32]"
+
+QA_PREBUILT="opt/${PN}/${PN}
+ opt/${PN}/setup"
+
+S="${WORKDIR}/${PN}"
+
+DIR="/opt/${PN}"
+WRITABLE=( "${EROOT}${DIR}"/{hwconfig.cfg,${PN}.{clr,cnt,scr}} )
+
+pkg_setup() {
+ enewgroup gamestat 36
+}
+
+src_prepare() {
+ default
+ rm -v *.dll || die
+}
+
+src_install() {
+ local EXES=( ${PN} setup )
+
+ insinto "${DIR}"
+ doins -r .
+
+ exeinto "${DIR}"
+ doexe "${EXES[@]}"
+
+ fowners root:gamestat "${EXES[@]/#/${DIR}/}" || die
+ fperms g+s "${EXES[@]/#/${DIR}/}" || die
+
+ make_wrapper ${PN} ./${PN} "${DIR}"
+ make_wrapper ${PN}-setup ./setup "${DIR}"
+}
+
+pkg_postinst() {
+ touch "${WRITABLE[@]}" || die
+ chown root:gamestat "${WRITABLE[@]}" || die
+ chmod 0664 "${WRITABLE[@]}" || die
+}
+
+pkg_prerm() {
+ [[ -z ${REPLACED_BY_VERSION} ]] &&
+ rm -v "${WRITABLE[@]}"
+}