summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2020-04-28 23:23:30 +0100
committerJames Le Cuirot <chewi@gentoo.org>2020-04-28 23:32:54 +0100
commit53e57f052f7a0f65f82c2a2bb27e1fe4686c9123 (patch)
tree058a80002ed55d92edc8b757d5463f975775d5bd /games-puzzle/world-of-goo-demo/world-of-goo-demo-1.41-r3.ebuild
parentgames-puzzle/world-of-goo-gog: Various improvements following split (diff)
downloadgentoo-53e57f052f7a0f65f82c2a2bb27e1fe4686c9123.tar.gz
gentoo-53e57f052f7a0f65f82c2a2bb27e1fe4686c9123.tar.bz2
gentoo-53e57f052f7a0f65f82c2a2bb27e1fe4686c9123.zip
games-puzzle/world-of-goo-demo: Use Slackbuilds mirror, EAPI 7
I tried to add USE=bundled-libs but the ancient Vorbis libraries clash with system Vorbis libraries pulled in via PulseAudio. Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'games-puzzle/world-of-goo-demo/world-of-goo-demo-1.41-r3.ebuild')
-rw-r--r--games-puzzle/world-of-goo-demo/world-of-goo-demo-1.41-r3.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/games-puzzle/world-of-goo-demo/world-of-goo-demo-1.41-r3.ebuild b/games-puzzle/world-of-goo-demo/world-of-goo-demo-1.41-r3.ebuild
new file mode 100644
index 000000000000..c25a8830d831
--- /dev/null
+++ b/games-puzzle/world-of-goo-demo/world-of-goo-demo-1.41-r3.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop eutils xdg
+
+MY_PN="WorldOfGooDemo"
+
+DESCRIPTION="A puzzle game with a strong emphasis on physics (demo version)"
+HOMEPAGE="https://2dboy.com/"
+SRC_URI="mirror://sourceforge/slackbuildsdirectlinks/worldofgoo/${MY_PN}.${PV}.tar.gz"
+
+LICENSE="2dboy-EULA"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="bindist mirror strip"
+
+RDEPEND="
+ media-libs/libsdl[opengl,sound,video]
+ media-libs/sdl-mixer[vorbis]
+ >=sys-devel/gcc-3.4
+ sys-libs/glibc
+ virtual/opengl
+ virtual/glu
+"
+
+dir="/opt/${PN}"
+S="${WORKDIR}/${MY_PN}"
+QA_PREBUILT="${dir#/}/*"
+
+src_install() {
+ exeinto "${dir}"
+ newexe ${MY_PN%Demo}.bin$(usex amd64 64 32) ${MY_PN%Demo}.bin
+ make_wrapper ${PN} ./${MY_PN%Demo}.bin "${dir}"
+
+ insinto "${dir}"
+ doins -r icons/ properties/ res/
+
+ local icon size
+ for icon in icons/*.{png,svg}; do
+ size=${icon##*/}
+ size=${size%%[x.]*}
+ newicon -s "${size}" "${icon}" "${PN}.${icon##*.}"
+ done
+
+ make_desktop_entry ${PN} "World of Goo (Demo)"
+
+ dodoc linux-issues.txt
+ docinto html
+ dodoc readme.html
+}