summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2018-05-01 18:08:38 +0200
committerPacho Ramos <pacho@gentoo.org>2018-05-01 21:34:56 +0200
commitab845aacccba9f31bb0804ddd77079bd85926b26 (patch)
tree6b1eff2568634ca959d4f1c6c8ae56ea69baf6f7 /games-puzzle/xpired
parentgames-puzzle/xblockout: Drop old (diff)
downloadgentoo-ab845aacccba9f31bb0804ddd77079bd85926b26.tar.gz
gentoo-ab845aacccba9f31bb0804ddd77079bd85926b26.tar.bz2
gentoo-ab845aacccba9f31bb0804ddd77079bd85926b26.zip
games-puzzle/xpired: Stop using games.eclass
Package-Manager: Portage-2.3.31, Repoman-2.3.9
Diffstat (limited to 'games-puzzle/xpired')
-rw-r--r--games-puzzle/xpired/xpired-1.22-r1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/games-puzzle/xpired/xpired-1.22-r1.ebuild b/games-puzzle/xpired/xpired-1.22-r1.ebuild
new file mode 100644
index 000000000000..8ea6b7243bf8
--- /dev/null
+++ b/games-puzzle/xpired/xpired-1.22-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit desktop
+
+DESCRIPTION="A Sokoban-styled puzzle game with lots more action"
+HOMEPAGE="http://xpired.sourceforge.net"
+SRC_URI="mirror://sourceforge/xpired/${P}-linux_source.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="media-libs/sdl-gfx
+ media-libs/sdl-image[jpeg]
+ media-libs/sdl-mixer[mod]"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/src"
+
+PATCHES=( "${FILESDIR}"/${P}-ldflags.patch )
+
+src_compile() {
+ emake \
+ PREFIX=/usr \
+ SHARE_PREFIX=/usr/share/xpired
+}
+
+src_install() {
+ emake \
+ PREFIX="${D}/usr" \
+ SHARE_PREFIX="${D}/usr/share/${PN}" \
+ install
+
+ newicon img/icon.bmp ${PN}.bmp
+ make_desktop_entry xpired Xpired /usr/share/pixmaps/${PN}.bmp
+ make_desktop_entry xpiredit "Xpired Level Editor"
+
+ einstalldocs
+}