summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2021-03-31 11:40:16 +0200
committerDavid Seifert <soap@gentoo.org>2021-03-31 11:40:16 +0200
commit0490b4b3276c58900eab8c2a798eecfa7060304f (patch)
treed4672c9f6bf36a10c969e302b172d6f74f155434 /games-puzzle
parentgames-puzzle/greedy: Port to EAPI 7 (diff)
downloadgentoo-0490b4b3276c58900eab8c2a798eecfa7060304f.tar.gz
gentoo-0490b4b3276c58900eab8c2a798eecfa7060304f.tar.bz2
gentoo-0490b4b3276c58900eab8c2a798eecfa7060304f.zip
games-puzzle/greedy: Add missing includes
Closes: https://bugs.gentoo.org/716566 Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'games-puzzle')
-rw-r--r--games-puzzle/greedy/files/greedy-0.2.0-missing-include.patch12
-rw-r--r--games-puzzle/greedy/greedy-0.2.0-r2.ebuild2
2 files changed, 14 insertions, 0 deletions
diff --git a/games-puzzle/greedy/files/greedy-0.2.0-missing-include.patch b/games-puzzle/greedy/files/greedy-0.2.0-missing-include.patch
new file mode 100644
index 000000000000..a728cde5b34e
--- /dev/null
+++ b/games-puzzle/greedy/files/greedy-0.2.0-missing-include.patch
@@ -0,0 +1,12 @@
+--- a/greedy.c
++++ b/greedy.c
+@@ -13,6 +13,9 @@
+
+ #include <ncurses.h>
+ #include <stdlib.h>
++#include <time.h>
++#include <unistd.h>
++#include <string.h>
+ #include "playmodes.h"
+ #include "playmodes.c"
+
diff --git a/games-puzzle/greedy/greedy-0.2.0-r2.ebuild b/games-puzzle/greedy/greedy-0.2.0-r2.ebuild
index 37e76149bcf1..aea669387c16 100644
--- a/games-puzzle/greedy/greedy-0.2.0-r2.ebuild
+++ b/games-puzzle/greedy/greedy-0.2.0-r2.ebuild
@@ -17,6 +17,8 @@ RDEPEND="sys-libs/ncurses:0="
DEPEND="${RDEPEND}"
BDEPEND="virtual/pkgconfig"
+PATCHES=( "${FILESDIR}"/${P}-missing-include.patch )
+
src_prepare() {
default