summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2020-04-28 23:19:21 +0100
committerJames Le Cuirot <chewi@gentoo.org>2020-04-28 23:32:47 +0100
commit4aa7f3fc09023a2a2f9f6964dceebb3c646a1972 (patch)
treefc3addf910e3a1c01733eb259e51ef81ba2432fd /games-puzzle
parentgames-puzzle/world-of-goo-gog-1.51.29337: new package (diff)
downloadgentoo-4aa7f3fc09023a2a2f9f6964dceebb3c646a1972.tar.gz
gentoo-4aa7f3fc09023a2a2f9f6964dceebb3c646a1972.tar.bz2
gentoo-4aa7f3fc09023a2a2f9f6964dceebb3c646a1972.zip
games-puzzle/world-of-goo-hb: Various improvements following split
* app-arch/unzip is BDEPEND, not DEPEND. * Use unpacker and xdg eclasses. * libsdl2[alsa] is not specifically needed. * virtual/glu is no longer needed. * Clarify pkg_nofetch text. * Use rpath rather than LD_LIBRARY_PATH. * Swap wrapper for symlink. Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'games-puzzle')
-rw-r--r--games-puzzle/world-of-goo-hb/world-of-goo-hb-1.53.ebuild50
1 files changed, 27 insertions, 23 deletions
diff --git a/games-puzzle/world-of-goo-hb/world-of-goo-hb-1.53.ebuild b/games-puzzle/world-of-goo-hb/world-of-goo-hb-1.53.ebuild
index e9b72ddc39b5..f08ef5823bf2 100644
--- a/games-puzzle/world-of-goo-hb/world-of-goo-hb-1.53.ebuild
+++ b/games-puzzle/world-of-goo-hb/world-of-goo-hb-1.53.ebuild
@@ -3,58 +3,62 @@
EAPI=7
-inherit desktop eutils # eutils for make_wrapper()
+inherit desktop unpacker xdg
MY_PN="WorldOfGoo"
-DESCRIPTION="A puzzle game with a strong emphasis on physics (HumbleBundle edition)"
-HOMEPAGE="http://2dboy.com/"
+DESCRIPTION="A puzzle game with a strong emphasis on physics (Humble Bundle edition)"
+HOMEPAGE="https://2dboy.com/"
SRC_URI="${MY_PN}.Linux.${PV}.sh"
LICENSE="2dboy-EULA"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="bundled-libs"
-RESTRICT="fetch bindist strip bundled-libs? ( splitdebug )"
+RESTRICT="bindist fetch strip bundled-libs? ( splitdebug )"
-DEPEND="app-arch/unzip"
-RDEPEND="!bundled-libs? (
- media-libs/libsdl2[alsa,sound,opengl,video]
+BDEPEND="app-arch/unzip"
+
+RDEPEND="
+ !bundled-libs? (
+ media-libs/libsdl2[opengl,sound,video]
media-libs/sdl2-mixer[vorbis]
)
+ >=sys-devel/gcc-3.4
sys-libs/glibc
virtual/opengl
- virtual/glu
- >=sys-devel/gcc-3.4
!games-puzzle/world-of-goo
- !games-puzzle/world-of-goo-gog"
+ !games-puzzle/world-of-goo-gog
+"
dir="/opt/${PN%-*}"
-
-QA_PREBUILT="${dir:1}/${MY_PN}.bin.x86
- ${dir:1}/${MY_PN}.bin.x86_64"
+S="${WORKDIR}"
+QA_PREBUILT="${dir#/}/*"
pkg_nofetch() {
- elog "Download ${A} from www.humblebundle.com"
- elog "and place it in your DISTDIR directory."
+ elog "If you bought directly from 2DBOY then download ${A} from:"
+ elog " https://2dboy.com/ReceptionistBot/orderLookup.php"
+ elog
+ elog "Otherwise please buy and download ${A} from:"
+ elog " https://www.humblebundle.com/store/product/worldofgoo"
+ elog
+ elog "Then move it to your distfiles directory."
}
src_unpack() {
- unzip -d "${S}" "${DISTDIR}/${A}"
+ unpack_zip ${A}
}
src_install() {
exeinto "${dir}"
- doexe data/x86$(usex amd64 _64)/${MY_PN}.bin.x86$(usex amd64 _64)
-
- make_wrapper ${PN%-*} "${dir}"/${MY_PN}.bin.x86$(usex amd64 _64) \
- $(use bundled-libs && (printf '"%s" "%s/lib%s"' "${dir}" "${dir}" $(usex amd64 64) || die))
+ newexe data/x86$(usex amd64 _64)/${MY_PN}.bin.x86$(usex amd64 _64) ${MY_PN}.bin
+ dosym "../..${dir}"/${MY_PN}.bin /usr/bin/${PN%-*}
insinto "${dir}"
- doins -r data/noarch/game
- use bundled-libs && doins -r data/x86$(usex amd64 _64)/lib$(usex amd64 64)
- newicon data/noarch/game/gooicon.png ${PN%-*}.png
+ doins -r data/noarch/game/
+ use bundled-libs && doins -r data/x86$(usex amd64 _64)/lib$(usex amd64 64)/
+ newicon -s 256 data/noarch/game/gooicon.png ${PN%-*}.png
make_desktop_entry ${PN%-*} "World of Goo" ${PN%-*}
docinto html