summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2018-05-01 14:08:14 +0200
committerPacho Ramos <pacho@gentoo.org>2018-05-01 21:33:03 +0200
commit9639206cfc5d996b3821607b73c0497571d1fd9b (patch)
tree9f812c0e803975ba6379234b227ee83bef8c529c /games-puzzle
parentgames-puzzle/gweled: Drop old (diff)
downloadgentoo-9639206cfc5d996b3821607b73c0497571d1fd9b.tar.gz
gentoo-9639206cfc5d996b3821607b73c0497571d1fd9b.tar.bz2
gentoo-9639206cfc5d996b3821607b73c0497571d1fd9b.zip
games-puzzle/hangman: Stop using games.eclass
Package-Manager: Portage-2.3.31, Repoman-2.3.9
Diffstat (limited to 'games-puzzle')
-rw-r--r--games-puzzle/hangman/hangman-0.9.2-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/games-puzzle/hangman/hangman-0.9.2-r1.ebuild b/games-puzzle/hangman/hangman-0.9.2-r1.ebuild
new file mode 100644
index 000000000000..abfc77ca017b
--- /dev/null
+++ b/games-puzzle/hangman/hangman-0.9.2-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit desktop
+
+DESCRIPTION="The classic word guessing game"
+HOMEPAGE="http://www.shiftygames.com/hangman/hangman.html"
+SRC_URI="http://www.shiftygames.com/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="!games-misc/bsd-games
+ media-libs/libsdl
+ media-libs/sdl-mixer
+ media-libs/sdl-image
+ media-libs/sdl-ttf"
+RDEPEND="${DEPEND}
+ sys-apps/miscfiles"
+
+src_prepare() {
+ default
+ sed -i \
+ -e 's/inline void SE_CheckEvents/void SE_CheckEvents/' \
+ src/hangman.c \
+ || die "sed failed"
+}
+
+src_install() {
+ default
+ newicon pics/noose.png ${PN}.png
+ make_desktop_entry ${PN} Hangman
+}