summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Sokolov <sokolov@google.com>2021-07-08 10:46:00 +0200
committerDavid Seifert <soap@gentoo.org>2021-07-08 10:46:00 +0200
commita1264b5ff3d7341248b30ca7e7bd82a7a9f658ce (patch)
treec0c57813a87b90b35db384331b2461bddd6de001 /games-puzzle
parentx11-themes/ubuntu-wallpapers: Drop old (diff)
downloadgentoo-a1264b5ff3d7341248b30ca7e7bd82a7a9f658ce.tar.gz
gentoo-a1264b5ff3d7341248b30ca7e7bd82a7a9f658ce.tar.bz2
gentoo-a1264b5ff3d7341248b30ca7e7bd82a7a9f658ce.zip
games-puzzle/construo: use correct AR
Closes: https://github.com/gentoo/gentoo/pull/21557 Closes: https://bugs.gentoo.org/801073 Package-Manager: Portage-3.0.20, Repoman-3.0.2 Signed-off-by: Alexey Sokolov <alexey+gentoo@asokolov.org> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'games-puzzle')
-rw-r--r--games-puzzle/construo/construo-0.2.3.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/games-puzzle/construo/construo-0.2.3.ebuild b/games-puzzle/construo/construo-0.2.3.ebuild
index 9e99b41dbdcb..89c4de46b053 100644
--- a/games-puzzle/construo/construo-0.2.3.ebuild
+++ b/games-puzzle/construo/construo-0.2.3.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit autotools desktop
+inherit autotools desktop toolchain-funcs
DESCRIPTION="2d construction toy with objects that react on physical forces"
HOMEPAGE="http://www.nongnu.org/construo/"
@@ -31,6 +31,10 @@ src_prepare() {
eautoreconf
}
+src_compile() {
+ emake AR=$(tc-getAR)
+}
+
src_install() {
default
make_desktop_entry "${PN}.glut" "${PN}.glut"