summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-04-18 09:55:03 -0400
committerMatt Turner <mattst88@gentoo.org>2021-04-18 09:56:07 -0400
commitb5e624b40e8a5654294f68ed7725cb994893ae8f (patch)
tree221bb48f6c3bb2443b307e9ab02ecd61c423f1d3 /games-puzzle
parentapp-text/fictionup: drop old (diff)
downloadgentoo-b5e624b40e8a5654294f68ed7725cb994893ae8f.tar.gz
gentoo-b5e624b40e8a5654294f68ed7725cb994893ae8f.tar.bz2
gentoo-b5e624b40e8a5654294f68ed7725cb994893ae8f.zip
games-puzzle/swell-foop: Fix compatibility with vala-0.50
Closes: https://bugs.gentoo.org/753866 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'games-puzzle')
-rw-r--r--games-puzzle/swell-foop/files/3.34.1-fix-vala-0.50.patch25
-rw-r--r--games-puzzle/swell-foop/swell-foop-3.34.1.ebuild4
2 files changed, 29 insertions, 0 deletions
diff --git a/games-puzzle/swell-foop/files/3.34.1-fix-vala-0.50.patch b/games-puzzle/swell-foop/files/3.34.1-fix-vala-0.50.patch
new file mode 100644
index 000000000000..ddc189ff54da
--- /dev/null
+++ b/games-puzzle/swell-foop/files/3.34.1-fix-vala-0.50.patch
@@ -0,0 +1,25 @@
+From a366bf649c032c56f52138d14e2b96b4a48525de Mon Sep 17 00:00:00 2001
+From: Rico Tzschichholz <ricotz@ubuntu.com>
+Date: Thu, 2 Jul 2020 15:28:02 +0200
+Subject: [PATCH] Don't use unsupported vala syntax
+
+---
+ src/game-view.vala | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/game-view.vala b/src/game-view.vala
+index 1fb0c4b..69b50b8 100644
+--- a/src/game-view.vala
++++ b/src/game-view.vala
+@@ -451,7 +451,7 @@ private class Theme : Object
+ internal Theme (string name)
+ {
+ textures = new Clutter.Image [4];
+- string[4] colors = {"blue", "green", "yellow", "red"};
++ string[] colors = {"blue", "green", "yellow", "red"};
+
+ /* Create the textures required to render */
+ try
+--
+2.26.3
+
diff --git a/games-puzzle/swell-foop/swell-foop-3.34.1.ebuild b/games-puzzle/swell-foop/swell-foop-3.34.1.ebuild
index 1073712ed558..d3d72fffdb64 100644
--- a/games-puzzle/swell-foop/swell-foop-3.34.1.ebuild
+++ b/games-puzzle/swell-foop/swell-foop-3.34.1.ebuild
@@ -27,6 +27,10 @@ BDEPEND="
$(vala_depend)
"
+PATCHES=(
+ "${FILESDIR}"/3.34.1-fix-vala-0.50.patch
+)
+
src_prepare() {
xdg_src_prepare
vala_src_prepare