summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-06 01:59:56 +0100
committerSam James <sam@gentoo.org>2021-04-06 19:17:46 +0100
commitd2aae58c28dc04ad6fce65c60d3ef352abdb7af8 (patch)
treeab393e502f59a8c4c90f91866eb8f20fc348e660 /games-puzzle
parentgames-emulation/dolphin: update cmake.eclass comment (diff)
downloadgentoo-d2aae58c28dc04ad6fce65c60d3ef352abdb7af8.tar.gz
gentoo-d2aae58c28dc04ad6fce65c60d3ef352abdb7af8.tar.bz2
gentoo-d2aae58c28dc04ad6fce65c60d3ef352abdb7af8.zip
games-puzzle/splice: port to EAPI 7, games.eclass--
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-puzzle')
-rw-r--r--games-puzzle/splice/splice-20121120-r1.ebuild (renamed from games-puzzle/splice/splice-20121120.ebuild)33
1 files changed, 16 insertions, 17 deletions
diff --git a/games-puzzle/splice/splice-20121120.ebuild b/games-puzzle/splice/splice-20121120-r1.ebuild
index d9b15617e47f..91d02c164129 100644
--- a/games-puzzle/splice/splice-20121120.ebuild
+++ b/games-puzzle/splice/splice-20121120-r1.ebuild
@@ -1,27 +1,29 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-# TODO: unbundle mono? (seems hardcoded)
-# icon
+EAPI=7
-EAPI=5
-
-inherit eutils games
+inherit desktop wrapper
DESCRIPTION="An experimental and artistic puzzler set in a microbial world"
HOMEPAGE="http://www.cipherprime.com/games/splice/"
SRC_URI="splice-linux-1353389454.tar.gz"
+S="${WORKDIR}"/Linux
LICENSE="all-rights-reserved"
SLOT="0"
KEYWORDS="-* ~amd64 ~x86"
-IUSE=""
+
RESTRICT="bindist fetch splitdebug"
-MYGAMEDIR=${GAMES_PREFIX_OPT}/${PN}
-QA_PREBUILT="${MYGAMEDIR#/}/Splice*
- ${MYGAMEDIR#/}/Splice_Data/Mono/*"
+MYGAMEDIR=opt/${PN}
+QA_PREBUILT="
+ ${MYGAMEDIR#/}/Splice*
+ ${MYGAMEDIR#/}/Splice_Data/Mono/*
+"
+# TODO: unbundle mono? (seems hardcoded)
+# icon
RDEPEND="
virtual/glu
virtual/opengl
@@ -29,8 +31,6 @@ RDEPEND="
x11-libs/libXcursor
x11-libs/libXext"
-S=${WORKDIR}/Linux
-
pkg_nofetch() {
einfo "Please buy & download ${SRC_URI} from:"
einfo " ${HOMEPAGE}"
@@ -38,7 +38,7 @@ pkg_nofetch() {
}
src_prepare() {
- einfo "removing ${ARCH} unrelated files..."
+ einfo "Removing ${ARCH} unrelated files..."
rm -v Splice.x86$(usex amd64 "" "_64") || die
rm -rv Splice_Data/Mono/x86$(usex amd64 "" "_64") || die
@@ -49,12 +49,11 @@ src_prepare() {
src_install() {
dodoc "${T}"/README
- insinto "${MYGAMEDIR}"
+ insinto ${MYGAMEDIR}
doins -r *
make_desktop_entry ${PN}
- games_make_wrapper ${PN} "./Splice.x86$(usex amd64 "_64" "")" "${MYGAMEDIR}"
+ make_wrapper ${PN} "./Splice.x86$(usex amd64 "_64" "")" "${MYGAMEDIR}"
- fperms +x "${MYGAMEDIR}"/Splice.x86$(usex amd64 "_64" "")
- prepgamesdirs
+ fperms +x ${MYGAMEDIR}/Splice.x86$(usex amd64 "_64" "")
}