summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2021-07-16 19:45:13 -0400
committerIonen Wolkens <ionen@gentoo.org>2021-07-17 03:58:47 -0400
commitfd23825e989d4b90ea3e2a89ccc1e1699a4c3e0a (patch)
tree28e7136767232d5fa50f5e3c9055d74d862c41d7 /games-puzzle
parentgames-puzzle/numptyphysics: add 0.3.8 (diff)
downloadgentoo-fd23825e989d4b90ea3e2a89ccc1e1699a4c3e0a.tar.gz
gentoo-fd23825e989d4b90ea3e2a89ccc1e1699a4c3e0a.tar.bz2
gentoo-fd23825e989d4b90ea3e2a89ccc1e1699a4c3e0a.zip
games-puzzle/numptyphysics: sync live
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'games-puzzle')
-rw-r--r--games-puzzle/numptyphysics/numptyphysics-9999.ebuild59
1 files changed, 15 insertions, 44 deletions
diff --git a/games-puzzle/numptyphysics/numptyphysics-9999.ebuild b/games-puzzle/numptyphysics/numptyphysics-9999.ebuild
index e9ab6b1a7e7d..738b4f617637 100644
--- a/games-puzzle/numptyphysics/numptyphysics-9999.ebuild
+++ b/games-puzzle/numptyphysics/numptyphysics-9999.ebuild
@@ -3,67 +3,38 @@
EAPI=7
-inherit git-r3 gnome2-utils toolchain-funcs
+inherit toolchain-funcs xdg
DESCRIPTION="Crayon Physics-like drawing puzzle game using the same excellent Box2D engine"
HOMEPAGE="https://github.com/thp/numptyphysics"
-EGIT_REPO_URI="https://github.com/thp/numptyphysics"
-# This is only the SRC_URI for the user levels. The code is in git repo.
-SRC_URI="user-levels? (
- http://numptyphysics.garage.maemo.org/levels/butelo/butelo.npz
- http://numptyphysics.garage.maemo.org/levels/catalyst/catalyst.npz
- http://numptyphysics.garage.maemo.org/levels/christeck/christeck.npz
- http://numptyphysics.garage.maemo.org/levels/dneary/dneary.npz
- http://numptyphysics.garage.maemo.org/levels/gnuton/gnuton.npz
- http://numptyphysics.garage.maemo.org/levels/gudger/gudger.npz
- http://numptyphysics.garage.maemo.org/levels/guile/guile.npz
- http://numptyphysics.garage.maemo.org/levels/hurd/hurd.npz
- http://numptyphysics.garage.maemo.org/levels/ioan/ioan.npz
- http://numptyphysics.garage.maemo.org/levels/jhoff80/jhoff80.npz
- http://numptyphysics.garage.maemo.org/levels/leonet/leonet.npz
- http://numptyphysics.garage.maemo.org/levels/melvin/melvin.npz
- http://numptyphysics.garage.maemo.org/levels/noodleman/noodleman.npz
- http://numptyphysics.garage.maemo.org/levels/papky/papky.npz
- http://numptyphysics.garage.maemo.org/levels/perli/perli.npz
- http://numptyphysics.garage.maemo.org/levels/qole/qole.npz
- http://numptyphysics.garage.maemo.org/levels/siminz/siminz.npz
- http://numptyphysics.garage.maemo.org/levels/szymanowski/szymanowski.npz
- http://numptyphysics.garage.maemo.org/levels/therealbubba/therealbubba.npz
- http://numptyphysics.garage.maemo.org/levels/werre/werre.npz
- http://numptyphysics.garage.maemo.org/levels/zeez/zeez.npz
-)"
-LICENSE="GPL-3+"
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/thp/numptyphysics.git"
+else
+ SRC_URI="https://github.com/thp/numptyphysics/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="BSD GPL-3+ ZLIB"
SLOT="0"
-IUSE="+user-levels"
RDEPEND="
dev-libs/glib:2
media-libs/libsdl2[opengl,video]
media-libs/sdl2-image[png]
media-libs/sdl2-ttf
- virtual/opengl
-"
+ virtual/opengl"
DEPEND="${RDEPEND}"
BDEPEND="virtual/pkgconfig"
PATCHES=(
- "${FILESDIR}"/${PN}-0.3.5-gentoo.patch
+ "${FILESDIR}"/${PN}-0.3.8-empty-tr.patch
+ "${FILESDIR}"/${PN}-0.3.8-respect-flags.patch
)
src_compile() {
- tc-export CC CXX
- emake
-}
-
-pkg_preinst() {
- gnome2_icon_savelist
-}
-
-pkg_postinst() {
- gnome2_icon_cache_update
-}
+ tc-export AR CC CXX PKG_CONFIG RANLIB
-pkg_postrm() {
- gnome2_icon_cache_update
+ emake V=1
}