summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2021-06-05 00:59:57 -0400
committerIonen Wolkens <ionen@gentoo.org>2021-06-05 01:04:00 -0400
commitfd68055c9bf71741752cd766b10b5d2c67479091 (patch)
tree919fe3df3aa14e0b373fdf16aa2f35afb59bafe3 /games-puzzle
parentgames-puzzle/pathological: support pygame-2, tidy ebuild (diff)
downloadgentoo-fd68055c9bf71741752cd766b10b5d2c67479091.tar.gz
gentoo-fd68055c9bf71741752cd766b10b5d2c67479091.tar.bz2
gentoo-fd68055c9bf71741752cd766b10b5d2c67479091.zip
games-puzzle/pathological: drop 1.1.3_p16-r2
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'games-puzzle')
-rw-r--r--games-puzzle/pathological/files/pathological-1.1.3-build-r1.patch12
-rw-r--r--games-puzzle/pathological/pathological-1.1.3_p16-r2.ebuild112
2 files changed, 0 insertions, 124 deletions
diff --git a/games-puzzle/pathological/files/pathological-1.1.3-build-r1.patch b/games-puzzle/pathological/files/pathological-1.1.3-build-r1.patch
deleted file mode 100644
index 48038df00036..000000000000
--- a/games-puzzle/pathological/files/pathological-1.1.3-build-r1.patch
+++ /dev/null
@@ -1,12 +0,0 @@
---- a/Makefile.old 2019-12-25 20:55:37.932303932 +0100
-+++ b/Makefile 2019-12-25 20:55:58.584530808 +0100
-@@ -4,9 +4,6 @@
-
- all: write-highscores docs
-
--write-highscores: write-highscores.c
-- gcc -s -o write-highscores write-highscores.c
--
- docs: html/wheel.png
- html/wheel.png:
- ./makehtml
diff --git a/games-puzzle/pathological/pathological-1.1.3_p16-r2.ebuild b/games-puzzle/pathological/pathological-1.1.3_p16-r2.ebuild
deleted file mode 100644
index 9a41e9a28b0f..000000000000
--- a/games-puzzle/pathological/pathological-1.1.3_p16-r2.ebuild
+++ /dev/null
@@ -1,112 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_{8,9} )
-
-inherit desktop python-single-r1 toolchain-funcs
-
-DESCRIPTION="An enriched clone of the game 'Logical' by Rainbow Arts"
-HOMEPAGE="http://pathological.sourceforge.net/"
-SRC_URI="
- mirror://sourceforge/${PN}/${P/_p*}.tar.gz
- mirror://debian/pool/main/${PN:0:1}/${PN}/${PN}_${PV/_p*}-${PV/*_p}.debian.tar.xz
-"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-IUSE="doc"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-# Note: locks up at start with >=pygame-2 (debian uses pygame-1, fix needed)
-RDEPEND="${PYTHON_DEPS}
- $(python_gen_cond_dep '
- >=dev-python/pygame-1.5.5[${PYTHON_USEDEP}]
- <dev-python/pygame-2[${PYTHON_USEDEP}]
- ')
-"
-DEPEND="${RDEPEND}"
-BDEPEND="${PYTHON_DEPS}
- doc? ( media-libs/netpbm )
-"
-
-S="${WORKDIR}/${P/_p*}"
-
-src_unpack() {
- unpack ${A}
- cd "${S}" || die
- unpack ./${PN}.6.gz
-}
-
-src_prepare() {
- default
-
- # Debian fixes
- # We don't face this bug, this way we skip needing to convert the
- # files at build time
- sed -i -e '/60_use_ogg_music.patch/d' "${WORKDIR}"/debian/patches/series || die
-
- for p in $(<"${WORKDIR}"/debian/patches/series) ; do
- eapply -p1 "${WORKDIR}/debian/patches/${p}"
- done
-
- # Fix prestripped files
- eapply "${FILESDIR}/${PN}-1.1.3-build-r1.patch"
-
- if use doc ; then
- sed -i -e '5,$ s/=/ /g' makehtml || die
- else
- echo "#!/bin/sh" > makehtml
- fi
-
- sed -i \
- -e "s:/usr/share/games:/usr/share:" \
- -e "s:exec:exec ${EPYTHON}:" \
- ${PN} || die
-
- sed -i \
- -e 's:\xa9:(C):' \
- -e "s:/usr/lib/${PN}/bin:/usr/$(get_libdir)/${PN}:" \
- ${PN}.py || die
-
- python_fix_shebang ${PN}.py
-
- tc-export CC
-}
-
-src_install() {
- dobin ${PN}
-
- exeinto /usr/"$(get_libdir)"/${PN}
- doexe write-highscores
-
- insinto /usr/share/${PN}
- doins -r circuits graphics music sounds ${PN}.py
-
- insinto /var/games/
- doins ${PN}_scores
- fperms 660 /var/games/${PN}_scores
-
- doman ${PN}.6
- use doc && local HTML_DOCS=( html/. )
- einstalldocs
- dodoc changelog
-
- doicon ${PN}.xpm
- make_desktop_entry ${PN} Pathological ${PN}
-
- # remove some unneeded resource files
- rm -f "${ED}"/usr/share/${PN}/graphics/*.xcf
-}
-
-pkg_postinst() {
- if ! has_version "media-libs/sdl-mixer[mod]" ; then
- echo
- elog "Since you have turned off the 'mod' use flag for media-libs/sdl-mixer"
- elog "no background music will be played."
- echo
- fi
-
-}