summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2018-06-25 16:06:48 +0200
committerLars Wendler <polynomial-c@gentoo.org>2018-06-25 16:07:03 +0200
commit3ea81b205878724228f404290b70f6e21195025a (patch)
tree97f380191023be13f0a72e8b5bf34b46c8ceb636 /games-roguelike/scourge/scourge-0.21.1-r1.ebuild
parentapp-admin/ps_mem: add SRC_URI arrow (diff)
downloadgentoo-3ea81b205878724228f404290b70f6e21195025a.tar.gz
gentoo-3ea81b205878724228f404290b70f6e21195025a.tar.bz2
gentoo-3ea81b205878724228f404290b70f6e21195025a.zip
games-roguelike/scourge: Replaced freetype-config with pkg-config
Closes: https://bugs.gentoo.org/655374 Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'games-roguelike/scourge/scourge-0.21.1-r1.ebuild')
-rw-r--r--games-roguelike/scourge/scourge-0.21.1-r1.ebuild16
1 files changed, 10 insertions, 6 deletions
diff --git a/games-roguelike/scourge/scourge-0.21.1-r1.ebuild b/games-roguelike/scourge/scourge-0.21.1-r1.ebuild
index 6f23afbb4196..5eeec7c52315 100644
--- a/games-roguelike/scourge/scourge-0.21.1-r1.ebuild
+++ b/games-roguelike/scourge/scourge-0.21.1-r1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit autotools eutils wxwidgets
+inherit autotools desktop wxwidgets
DESCRIPTION="A graphical rogue-like adventure game"
HOMEPAGE="https://sourceforge.net/projects/scourge/"
@@ -25,14 +25,16 @@ RDEPEND="
virtual/opengl
virtual/glu"
DEPEND="${RDEPEND}
- sys-devel/gettext"
+ sys-devel/gettext
+ virtual/pkgconfig"
-S=${WORKDIR}/${PN}
+S="${WORKDIR}/${PN}"
PATCHES=(
"${FILESDIR}"/${P}-gcc47.patch
"${FILESDIR}"/${P}-gcc6.patch
"${FILESDIR}"/${P}-automake-1.13.patch
+ "${FILESDIR}"/${P}-freetype_pkgconfig.patch
)
src_prepare() {
@@ -50,9 +52,11 @@ src_prepare() {
}
src_configure() {
- econf \
- --with-data-dir=/usr/share/${PN} \
+ local myeconfargs=(
+ --with-data-dir=/usr/share/${PN}
--localedir=/usr/share/locale
+ )
+ econf "${myeconfargs[@]}"
}
src_install() {