summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-05 17:40:02 +0000
committerSam James <sam@gentoo.org>2021-04-05 17:45:48 +0000
commit26aadfd8089d9478bc029d4b7dd127844c1ae1c9 (patch)
tree5aede196b5b5f10764d8cd19d276714fe6f3fda5 /games-roguelike/tome
parentgames-roguelike/hengband: eutils-- (diff)
downloadgentoo-26aadfd8089d9478bc029d4b7dd127844c1ae1c9.tar.gz
gentoo-26aadfd8089d9478bc029d4b7dd127844c1ae1c9.tar.bz2
gentoo-26aadfd8089d9478bc029d4b7dd127844c1ae1c9.zip
games-roguelike/tome: fix games.eclass porting, pkgconfig calls, multilib--
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-roguelike/tome')
-rw-r--r--games-roguelike/tome/tome-2.3.5.ebuild67
1 files changed, 46 insertions, 21 deletions
diff --git a/games-roguelike/tome/tome-2.3.5.ebuild b/games-roguelike/tome/tome-2.3.5.ebuild
index 66f77bb1c077..e7b97c6f3709 100644
--- a/games-roguelike/tome/tome-2.3.5.ebuild
+++ b/games-roguelike/tome/tome-2.3.5.ebuild
@@ -1,40 +1,47 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit multilib
+
+inherit toolchain-funcs
MY_PV=${PV//./}
DESCRIPTION="save the world from Morgoth and battle evil (or become evil ;])"
HOMEPAGE="http://t-o-m-e.net/"
SRC_URI="http://t-o-m-e.net/dl/src/tome-${MY_PV}-src.tar.bz2"
+S="${WORKDIR}"/tome-${MY_PV}-src/src
LICENSE="Moria"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="X Xaw3d gtk sdl"
+IUSE="gtk sdl X Xaw3d"
-RDEPEND=">=sys-libs/ncurses-5:0
- X? ( x11-libs/libX11 )
- Xaw3d? ( x11-libs/libXaw )
+RDEPEND="
+ >=sys-libs/ncurses-5:0=
sdl? (
media-libs/sdl-ttf
media-libs/sdl-image
media-libs/libsdl )
- gtk? ( >=x11-libs/gtk+-2.12.8:2 ) "
-DEPEND="${RDEPEND}
+ gtk? ( >=x11-libs/gtk+-2.12.8:2 )
+ X? ( x11-libs/libX11 )
+ Xaw3d? ( x11-libs/libXaw )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
virtual/pkgconfig
- x11-misc/makedepend"
+ x11-misc/makedepend
+"
-S=${WORKDIR}/tome-${MY_PV}-src/src
+RDEPEND+=" acct-group/gamestat"
-PATCHES=( "${FILESDIR}/${PN}-2.3.5-gentoo-paths.patch"
+PATCHES=(
+ "${FILESDIR}/"${PN}-2.3.5-gentoo-paths.patch
"${FILESDIR}"/${PN}-2.3.5-format.patch
"${FILESDIR}"/${PN}-2.3.5-noX.patch
)
src_prepare() {
- mv makefile.std makefile
+ mv makefile.std makefile || die
default
@@ -42,54 +49,67 @@ src_prepare() {
sed -i -e "s:xx:x:" ../lib/edit/p_info.txt || die
# sed -i -e "s:GENTOO_DIR:${GAMES_STATEDIR}:" files.c init2.c || die
- find .. -name .cvsignore -exec rm -f \{\} +
- find ../lib/edit -type f -exec chmod a-x \{\} +
+ find .. -name .cvsignore -exec rm -f \{\} + || die
+ find ../lib/edit -type f -exec chmod a-x \{\} + || die
}
src_compile() {
- local GENTOO_INCLUDES="" GENTOO_DEFINES="-DUSE_GCU " GENTOO_LIBS="$(pkg-config ncurses --libs)"
+ tc-export CC
+
+ local GENTOO_INCLUDES="" GENTOO_DEFINES="-DUSE_GCU " GENTOO_LIBS="$($(tc_getPKG_CONFIG) ncurses --libs)"
+
if use sdl || use X || use gtk || use Xaw3d; then
GENTOO_DEFINES="${GENTOO_DEFINES} -DUSE_EGO_GRAPHICS -DUSE_TRANSPARENCY \
-DSUPPORT_GAMMA"
fi
+
if use sdl || use X || use Xaw3d; then
GENTOO_DEFINES="${GENTOO_DEFINES} -DUSE_PRECISE_CMOVIE -DUSE_UNIXSOCK "
fi
+
if use sdl; then
GENTOO_INCLUDES="${GENTOO_INCLUDES} $(sdl-config --cflags)"
GENTOO_DEFINES="${GENTOO_DEFINES} -DUSE_SDL "
GENTOO_LIBS="${GENTOO_LIBS} $(sdl-config --libs) -lSDL_image -lSDL_ttf"
fi
+
if use X; then
GENTOO_INCLUDES="${GENTOO_INCLUDES} -I/usr/X11R6/include "
GENTOO_DEFINES="${GENTOO_DEFINES} -DUSE_X11 "
GENTOO_LIBS="${GENTOO_LIBS} -L/usr/X11R6/lib -lX11 "
fi
+
if use Xaw3d; then
GENTOO_INCLUDES="${GENTOO_INCLUDES} -I/usr/X11R6/include "
GENTOO_DEFINES="${GENTOO_DEFINES} -DUSE_XAW "
GENTOO_LIBS="${GENTOO_LIBS} -L/usr/X11R6/lib -lXaw -lXmu -lXt -lX11 "
fi
+
if use gtk; then
- GENTOO_INCLUDES="${GENTOO_INCLUDES} $(pkg-config gtk+-2.0 --cflags)"
+ GENTOO_INCLUDES="${GENTOO_INCLUDES} $($(tc_getPKG_CONFIG) gtk+-2.0 --cflags)"
GENTOO_DEFINES="${GENTOO_DEFINES} -DUSE_GTK2 "
- GENTOO_LIBS="${GENTOO_LIBS} $(pkg-config gtk+-2.0 --libs) "
+ GENTOO_LIBS="${GENTOO_LIBS} $($(tc_getPKG_CONFIG) gtk+-2.0 --libs) "
GTK_SRC_FILE="main-gtk2.c"
GTK_OBJ_FILE="main-gtk2.o"
else
GTK_SRC_FILE=""
GTK_OBJ_FILE=""
fi
+
if use amd64; then
GENTOO_DEFINES="${GENTOO_DEFINES} -DLUA_NUM_TYPE=int "
fi
+
GENTOO_INCLUDES="${GENTOO_INCLUDES} -Ilua -I."
GENTOO_DEFINES="${GENTOO_DEFINES} -DUSE_LUA"
+
emake -j1 \
INCLUDES="${GENTOO_INCLUDES}" \
DEFINES="${GENTOO_DEFINES}" \
depend
- emake ./tolua
+
+ emake tolua
+
emake \
COPTS="${CFLAGS}" \
INCLUDES="${GENTOO_INCLUDES}" \
@@ -107,11 +127,16 @@ src_install() {
OWNER="nobody" \
BINDIR="${EPREFIX}/usr/bin" \
LIBDIR="${EPREFIX}/usr/$(get_libdir)/${PN}" install
- cd ..
+
+ cd .. || die
dodoc *.txt
- dodir "/var/games"
- touch "${D}/var/games/${PN}-scores.raw"
+ dodir /var/games
+ touch "${ED}/var/games/${PN}-scores.raw" || die
+
+ fperms 660 /var/games/${PN}-scores.raw
+ fowners root:gamestat /var/games/${PN}-scores.raw
+ fperms g+s /usr/bin/${PN}
}
pkg_postinst() {