summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2015-11-06 00:29:53 -0500
committerMichael Sterrett <mr_bones_@gentoo.org>2015-11-06 00:29:53 -0500
commitaa2734763bbfc4e87a8f052c88fa452f726991c1 (patch)
treebf0936e1878801f893ef973af7b835f9c9d3c252 /games-roguelike
parentnet-misc/stunnel: Stable for HPPA (bug #564710). (diff)
downloadgentoo-aa2734763bbfc4e87a8f052c88fa452f726991c1.tar.gz
gentoo-aa2734763bbfc4e87a8f052c88fa452f726991c1.tar.bz2
gentoo-aa2734763bbfc4e87a8f052c88fa452f726991c1.zip
version bump (bug #564118)
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'games-roguelike')
-rw-r--r--games-roguelike/angband/Manifest1
-rw-r--r--games-roguelike/angband/angband-4.0.3.ebuild116
2 files changed, 117 insertions, 0 deletions
diff --git a/games-roguelike/angband/Manifest b/games-roguelike/angband/Manifest
index e146ae8dbbbe..5c7c7c7def2c 100644
--- a/games-roguelike/angband/Manifest
+++ b/games-roguelike/angband/Manifest
@@ -1,2 +1,3 @@
+DIST angband-4.0.3.tar.gz 19884304 SHA256 1752d22a164bb073b9a7be322a2b607b06a4c919c073d012c010a61578081ce8 SHA512 c900648b6972e27ab30aaac776bbad34aee2196b5b80c4574762ff21c7c42a42061f76379ec4c0c2aefdfd1647aa76f2bd9fdd0286a7bc762616d97799e51a24 WHIRLPOOL 45c6eb4b71bf51bf2d41d270a8bb699d924137ccce605df867bf098f8545067c405a4ea851fe25e37304c908a13dd4e41229bf653bb87632f2fedb64323f2363
DIST angband-v3.4.1.tar.gz 17880537 SHA256 461e36d22c15df330b4d4eaa850e4f2c2da6731d23e99fa13a056249343fd945 SHA512 76099c8fa999e88ea1324bb70b4dee5df1faccd1fa256cc0c460ce2c5ddae9634fdef876bd0d826e99e6dcc54a9f9cf619d82552dc658d0115b97e0e644c19d3 WHIRLPOOL 4e74092deb1868a7c172c206058ebf198f5bdf08f50ebfa5cd3a4a4200998283d9d1896ff39f41fa88f74b78940bee16a3f8a2ce949a69b3e01417017cc32545
DIST angband-v3.5.1.tar.gz 20539732 SHA256 c5ca3ab75fd820a49eb2b9ab8b1c2a811ff992276f9800cc61c686e90bd4d447 SHA512 a45a64b4de1161f327594b93177432c22a00301e7e6058a5e9c1407343c4448217564303578d46f3ea15c94b86aeaf813685a04a70a5dae58511cbf0427b86dc WHIRLPOOL b5f32d90b9923c8ea00eae762b3e743f3d1175290feb5bd38064a29954e8685545eb2129eabcb98e2386f7d425c9ce966c8824634844d23dd91dbbd8b32586bd
diff --git a/games-roguelike/angband/angband-4.0.3.ebuild b/games-roguelike/angband/angband-4.0.3.ebuild
new file mode 100644
index 000000000000..dec221f9f4b2
--- /dev/null
+++ b/games-roguelike/angband/angband-4.0.3.ebuild
@@ -0,0 +1,116 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools eutils gnome2-utils versionator games
+
+MAJOR_PV=$(get_version_component_range 1-2)
+
+DESCRIPTION="A roguelike dungeon exploration game based on the books of J.R.R. Tolkien"
+HOMEPAGE="http://rephial.org/"
+SRC_URI="http://rephial.org/downloads/${MAJOR_PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="ncurses sdl +sound X"
+
+RDEPEND="X? ( x11-libs/libX11 )
+ !ncurses? ( !X? ( !sdl? ( sys-libs/ncurses[unicode] ) ) )
+ ncurses? ( sys-libs/ncurses[unicode] )
+ sdl? ( media-libs/libsdl[video,X]
+ media-libs/sdl-ttf
+ media-libs/sdl-image
+ sound? ( media-libs/sdl-mixer[mp3]
+ media-libs/libsdl[sound] ) )"
+DEPEND="${RDEPEND}
+ dev-python/docutils
+ virtual/pkgconfig"
+
+src_prepare() {
+
+ sed -i -e '/libpath/s#datarootdir#datadir#' configure.ac || die
+ sed -i -e "/^.SILENT/d" mk/buildsys.mk.in || die
+ sed -i -e '/^DOC =/s/=.*/=/' doc/Makefile || die
+
+ if use !sound ; then
+ sed -i -e 's/sounds//' lib/Makefile || die
+ fi
+
+ # Game constant files are now system config files in Angband, but
+ # users will be hidden from applying updates by default
+ {
+ echo "CONFIG_PROTECT_MASK=\"${GAMES_SYSCONFDIR}/${PN}/customize/\""
+ echo "CONFIG_PROTECT_MASK=\"${GAMES_SYSCONFDIR}/${PN}/gamedata/\""
+ } > "${T}"/99${PN} || die
+
+ eautoreconf
+}
+
+src_configure() {
+ local myconf
+
+ if use sdl; then
+ myconf="$(use_enable sound sdl-mixer)"
+ else
+ myconf="--disable-sdl-mixer"
+ fi
+
+ egamesconf \
+ --bindir="${GAMES_BINDIR}" \
+ --with-private-dirs \
+ $(use_enable X x11) \
+ $(use_enable sdl) \
+ $(use_enable ncurses curses) \
+ $(use !sdl && use !ncurses && use !X && \
+ echo --enable-curses) \
+ ${myconf}
+}
+
+src_install() {
+ DOCS="changes.txt faq.txt readme.txt thanks.txt" \
+ default
+
+ dohtml doc/manual.html
+ doenvd "${T}"/99${PN}
+
+ if use X || use sdl ; then
+ if use X; then
+ make_desktop_entry "angband -mx11" "Angband (X11)" "${PN}"
+ fi
+
+ if use sdl; then
+ make_desktop_entry "angband -msdl" "Angband (SDL)" "${PN}"
+ fi
+
+ local s
+ for s in 16 32 128 256 512
+ do
+ newicon -s ${s} lib/icons/att-${s}.png "${PN}.png"
+ done
+ newicon -s scalable lib/icons/att.svg "${PN}.svg"
+ fi
+
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ if use X || use sdl ; then
+ gnome2_icon_savelist
+ fi
+}
+
+pkg_postinst() {
+ echo
+ elog "Angband now uses private savefiles instead of system-wide ones."
+ elog "This version of Angband is not compatible with the save files"
+ elog "of previous versions."
+ echo
+
+ games_pkg_postinst
+ if use X || use sdl ; then
+ gnome2_icon_cache_update
+ fi
+}