summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-rpg/arx-libertatis/arx-libertatis-1.1.2.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-rpg/arx-libertatis/arx-libertatis-1.1.2.ebuild')
-rw-r--r--games-rpg/arx-libertatis/arx-libertatis-1.1.2.ebuild98
1 files changed, 98 insertions, 0 deletions
diff --git a/games-rpg/arx-libertatis/arx-libertatis-1.1.2.ebuild b/games-rpg/arx-libertatis/arx-libertatis-1.1.2.ebuild
new file mode 100644
index 000000000000..d238e63a52fe
--- /dev/null
+++ b/games-rpg/arx-libertatis/arx-libertatis-1.1.2.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+CMAKE_WARN_UNUSED_CLI=yes
+inherit eutils cmake-utils gnome2-utils games
+
+DESCRIPTION="Cross-platform port of Arx Fatalis, a first-person role-playing game"
+HOMEPAGE="http://arx-libertatis.org/"
+SRC_URI="mirror://sourceforge/arx/${P}/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="c++0x debug +unity-build crash-reporter static tools"
+
+COMMON_DEPEND="
+ media-libs/freetype
+ media-libs/libsdl[X,video,opengl]
+ media-libs/openal
+ sys-libs/zlib
+ virtual/opengl
+ crash-reporter? (
+ dev-qt/qtcore:4[ssl]
+ dev-qt/qtgui:4
+ )
+ !static? ( media-libs/glew )"
+RDEPEND="${COMMON_DEPEND}
+ crash-reporter? ( sys-devel/gdb )"
+DEPEND="${COMMON_DEPEND}
+ dev-libs/boost
+ virtual/pkgconfig
+ static? ( media-libs/glew[static-libs] )"
+
+DOCS=( README.md AUTHORS CHANGELOG )
+
+src_configure() {
+ # editor does not build
+ local mycmakeargs=(
+ $(cmake-utils_use_build crash-reporter CRASHREPORTER)
+ -DBUILD_EDITOR=OFF
+ $(cmake-utils_use_build tools TOOLS)
+ -DCMAKE_INSTALL_DATAROOTDIR="${GAMES_DATADIR_BASE}"
+ -DCMAKE_INSTALL_PREFIX="${GAMES_PREFIX}"
+ $(cmake-utils_use debug DEBUG)
+ -DGAMESBINDIR="${GAMES_BINDIR}"
+ -DICONDIR=/usr/share/icons/hicolor/128x128/apps
+ -DINSTALL_SCRIPTS=ON
+ -DSET_OPTIMIZATION_FLAGS=OFF
+ -DSTRICT_USE=ON
+ $(cmake-utils_use unity-build UNITY_BUILD)
+ $(cmake-utils_use_use c++0x CXX11)
+ -DUSE_NATIVE_FS=ON
+ -DUSE_OPENAL=ON
+ -DUSE_OPENGL=ON
+ -DUSE_SDL=ON
+ $(usex crash-reporter "-DUSE_QT5=OFF" "")
+ $(cmake-utils_use_use static STATIC_LIBS)
+ )
+
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+}
+
+src_install() {
+ cmake-utils_src_install
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ elog "optional dependencies:"
+ elog " games-rpg/arx-fatalis-data (from CD or GOG)"
+ elog " games-rpg/arx-fatalis-demo (free demo)"
+ elog
+ elog "This package only installs the game binary."
+ elog "You need the demo or full game data. Also see:"
+ elog "http://wiki.arx-libertatis.org/Getting_the_game_data"
+ elog
+ elog "If you have already installed the game or use the STEAM version,"
+ elog "run \"${GAMES_BINDIR}/arx-install-data\""
+
+ games_pkg_postinst
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}