summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-rpg/arx-libertatis/files/arx-libertatis-1.0.3-gentoo.patch
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-rpg/arx-libertatis/files/arx-libertatis-1.0.3-gentoo.patch')
-rw-r--r--games-rpg/arx-libertatis/files/arx-libertatis-1.0.3-gentoo.patch74
1 files changed, 74 insertions, 0 deletions
diff --git a/games-rpg/arx-libertatis/files/arx-libertatis-1.0.3-gentoo.patch b/games-rpg/arx-libertatis/files/arx-libertatis-1.0.3-gentoo.patch
new file mode 100644
index 000000000000..c1da7f7136d1
--- /dev/null
+++ b/games-rpg/arx-libertatis/files/arx-libertatis-1.0.3-gentoo.patch
@@ -0,0 +1,74 @@
+From: Julian Ospald <hasufell@gentoo.org>
+Date: Wed Jun 27 22:04:32 UTC 2012
+Subject: build system
+
+respect flags
+
+--- CMakeLists.txt
++++ CMakeLists.txt
+@@ -365,21 +365,6 @@
+
+ endif()
+
+- # Warning level
+- add_cxxflag("-Wall")
+- add_cxxflag("-Wextra")
+- add_cxxflag("-Wformat=2")
+- add_cxxflag("-Wundef")
+- add_cxxflag("-Wpointer-arith")
+- add_cxxflag("-Wcast-qual")
+- add_cxxflag("-Woverloaded-virtual")
+- add_cxxflag("-Wlogical-op")
+-
+- add_cxxflag("-Wliteral-conversion")
+- add_cxxflag("-Wshift-overflow")
+- add_cxxflag("-Woverflow")
+- add_cxxflag("-Wbool-conversions")
+-
+ # TODO enable:
+ # add_cxxflag("-Wconversion") # very noisy
+ # add_cxxflag("-Wsign-conversion") # very noisy
+@@ -391,27 +376,12 @@
+ endif()
+
+ if(CMAKE_BUILD_TYPE STREQUAL "Debug")
+-
+- #Debug
+ add_definitions(-D_DEBUG)
+-
+- check_compiler_flag(RESULT "-g3")
+- if(NOT RESULT STREQUAL "")
+- string(REGEX REPLACE "-g(|[0-9]|gdb)" "" CMAKE_CXX_FLAGS_DEBUG "${CMAKE_CXX_FLAGS_DEBUG}")
+- set(CMAKE_CXX_FLAGS_DEBUG "${CMAKE_CXX_FLAGS_DEBUG} ${RESULT}")
+- endif()
+-
+- check_compiler_flag(RESULT "-O0")
+- string(REGEX REPLACE "-O[0-9]" "" CMAKE_CXX_FLAGS_DEBUG "${CMAKE_CXX_FLAGS_DEBUG}")
+- set(CMAKE_CXX_FLAGS_DEBUG "${CMAKE_CXX_FLAGS_DEBUG} ${RESULT}")
+-
+ elseif(CMAKE_BUILD_TYPE STREQUAL "Release")
+-
+ if((NOT CMAKE_CXX_FLAGS MATCHES "-g(|[0-9]|gdb)")
+ AND (NOT CMAKE_CXX_FLAGS_RELEASE MATCHES "-g(|[0-9]|gdb)"))
+ add_cxxflag("-g2")
+ endif()
+-
+ endif()
+
+ if(DEBUG_EXTRA)
+@@ -419,15 +389,7 @@
+ add_cxxflag("-fbounds-checking")
+ add_cxxflag("-fcatch-undefined-behavior")
+ add_cxxflag("-Wstrict-aliasing=1")
+- else()
+- # -Wuninitialized causes too many false positives
+- add_cxxflag("-Wno-uninitialized")
+- # (clang only) Conflicts with using const variables for configuration.
+- add_cxxflag("-Wno-constant-logical-operand")
+ endif()
+-
+- # Because we are lazy
+- add_ldflag("-Wl,--as-needed")
+
+ # Xcode does not support -isystem yet
+ if(${CMAKE_SYSTEM_NAME} MATCHES "Darwin")