summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-rpg/dear-esther
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-rpg/dear-esther')
-rw-r--r--games-rpg/dear-esther/Manifest1
-rw-r--r--games-rpg/dear-esther/dear-esther-20130608.ebuild73
-rw-r--r--games-rpg/dear-esther/metadata.xml5
3 files changed, 79 insertions, 0 deletions
diff --git a/games-rpg/dear-esther/Manifest b/games-rpg/dear-esther/Manifest
new file mode 100644
index 000000000000..f4ce83570062
--- /dev/null
+++ b/games-rpg/dear-esther/Manifest
@@ -0,0 +1 @@
+DIST dearesther-linux-06082013-bin 1007461686 SHA256 4b3368e9cd83f371b6ea63814ce1ec5db733d5ef3229e3f78bdc530c268076a4 SHA512 c66a2b068b4caaebfb63e4617102af4a5df153dfe76854d1fa94305fb95b15e4362c9ca5e715ea4b29966916a9a585fa71bfc2b2b33b878f26e3785b7d93722e WHIRLPOOL 022d2fe66dfb2f4bea71898afd6f011ffe5870c5af27e3adb04fe5caa76a41bce75ee931408edda41dc24956ddae4f2399719f3938d72fe9cf94b2a9e2e703ea
diff --git a/games-rpg/dear-esther/dear-esther-20130608.ebuild b/games-rpg/dear-esther/dear-esther-20130608.ebuild
new file mode 100644
index 000000000000..2443f5a1454c
--- /dev/null
+++ b/games-rpg/dear-esther/dear-esther-20130608.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+# TODO: unbundle libSDL2
+
+EAPI=5
+inherit eutils gnome2-utils unpacker games
+
+TIMESTAMP="${PV:4:2}${PV:6:2}${PV:0:4}"
+DESCRIPTION="Ghost story, told using first-person gaming technologies"
+HOMEPAGE="http://dear-esther.com/"
+SRC_URI="dearesther-linux-${TIMESTAMP}-bin"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="-* amd64 x86"
+IUSE=""
+RESTRICT="bindist fetch splitdebug"
+
+MYGAMEDIR=${GAMES_PREFIX_OPT}/${PN}
+QA_PREBUILT="${MYGAMEDIR#/}/dearesther_linux
+ ${MYGAMEDIR#/}/bin/*.so*"
+
+DEPEND="app-arch/unzip"
+RDEPEND="
+ >=media-libs/freetype-2.5.0.1[abi_x86_32(-)]
+ >=media-libs/libsdl-1.2.15-r5[abi_x86_32(-)]
+ >=media-libs/openal-1.15.1[abi_x86_32(-)]
+ x11-libs/libX11[abi_x86_32(-)]
+ virtual/opengl[abi_x86_32(-)]"
+
+S=${WORKDIR}/data
+
+pkg_nofetch() {
+ einfo "Please buy & download ${SRC_URI} from:"
+ einfo " ${HOMEPAGE}"
+ einfo "and move it to ${DISTDIR}"
+ einfo
+}
+
+src_unpack() {
+ unpack_zip ${A}
+}
+
+src_install() {
+ insinto "${MYGAMEDIR}"
+ doins -r bin dearesther platform dearesther_linux
+
+ doicon -s 256 dearesther.png
+ make_desktop_entry "${PN}" "Dear Esther" dearesther
+ games_make_wrapper ${PN} "./dearesther_linux -game dearesther" "${MYGAMEDIR}" "${MYGAMEDIR}/bin"
+
+ dodoc README-linux.txt
+
+ fperms +x "${MYGAMEDIR}"/dearesther_linux
+
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}
diff --git a/games-rpg/dear-esther/metadata.xml b/games-rpg/dear-esther/metadata.xml
new file mode 100644
index 000000000000..cad5a2aa1773
--- /dev/null
+++ b/games-rpg/dear-esther/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+</pkgmetadata>