summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-rpg/eternal-lands-bloodsucker
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-rpg/eternal-lands-bloodsucker')
-rw-r--r--games-rpg/eternal-lands-bloodsucker/Manifest2
-rw-r--r--games-rpg/eternal-lands-bloodsucker/eternal-lands-bloodsucker-3.0.ebuild37
-rw-r--r--games-rpg/eternal-lands-bloodsucker/eternal-lands-bloodsucker-3.0_p20110618.ebuild37
-rw-r--r--games-rpg/eternal-lands-bloodsucker/metadata.xml10
4 files changed, 86 insertions, 0 deletions
diff --git a/games-rpg/eternal-lands-bloodsucker/Manifest b/games-rpg/eternal-lands-bloodsucker/Manifest
new file mode 100644
index 000000000000..4d7cc8a50807
--- /dev/null
+++ b/games-rpg/eternal-lands-bloodsucker/Manifest
@@ -0,0 +1,2 @@
+DIST eternal-lands-bloodsucker-3.0.zip 56684190 SHA256 656e00bdb5910d17de81547ef359a0b1bca3246f08efbf1e3072079b84a9e886
+DIST eternal-lands-bloodsucker-3.0_p20110618.tar.bz2 48324713 SHA256 bfc347a9b17c9673ef7ae225ec690e3c55e07b33a57e484415baf88ea4e15730 SHA512 951083ae5170929d64efa79962a19ab2481df956c316aecc32179478c4d56dd4d23282fa428974865216877b493a8729bdbedb0396b6c11670f6ee094c334fe4 WHIRLPOOL 96fe24a740b3fa6e9ec6a6052edd940bb98042beda6344b4d5614938d03e11c5661c79ebb5bb7a7b8f0e55c31758d1bfb4418e5fdcca03b568ebd58b25512521
diff --git a/games-rpg/eternal-lands-bloodsucker/eternal-lands-bloodsucker-3.0.ebuild b/games-rpg/eternal-lands-bloodsucker/eternal-lands-bloodsucker-3.0.ebuild
new file mode 100644
index 000000000000..aa2d28d9db5c
--- /dev/null
+++ b/games-rpg/eternal-lands-bloodsucker/eternal-lands-bloodsucker-3.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+
+inherit eutils games
+
+DESCRIPTION="Non-official map pack for Eternal Lands"
+HOMEPAGE="http://maps.el-pl.org/"
+SRC_URI="mirror://gentoo/${P}.zip"
+LICENSE="CC-BY-NC-SA-3.0"
+SLOT="0"
+
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+
+IUSE=""
+
+DEPEND="games-rpg/eternal-lands-data[bloodsuckermaps]"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"
+
+src_install() {
+ insopts -m 0660
+ insinto "${GAMES_DATADIR}/eternal-lands"
+ doins -r maps || die "doins failed"
+
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ elog "Note that the Bloodsucker Maps are not official maps and are not"
+ elog "supported by the Eternal Lands team."
+ elog "Please do not bother Eternal Lands staff about bugs with the maps."
+}
diff --git a/games-rpg/eternal-lands-bloodsucker/eternal-lands-bloodsucker-3.0_p20110618.ebuild b/games-rpg/eternal-lands-bloodsucker/eternal-lands-bloodsucker-3.0_p20110618.ebuild
new file mode 100644
index 000000000000..2043fa1b9350
--- /dev/null
+++ b/games-rpg/eternal-lands-bloodsucker/eternal-lands-bloodsucker-3.0_p20110618.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils games
+
+DESCRIPTION="Non-official map pack for Eternal Lands"
+HOMEPAGE="http://maps.el-pl.org/"
+SRC_URI="http://dev.gentoo.org/~rich0/distfiles/${P}.tar.bz2"
+LICENSE="CC-BY-NC-SA-3.0"
+SLOT="0"
+
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+
+IUSE=""
+
+DEPEND="games-rpg/eternal-lands-data[bloodsuckermaps]"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"
+
+src_install() {
+ insopts -m 0660
+ insinto "${GAMES_DATADIR}/eternal-lands"
+ doins -r maps
+
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ elog "Note that the Bloodsucker Maps are not official maps and are not"
+ elog "supported by the Eternal Lands team."
+ elog "Please do not bother Eternal Lands staff about bugs with the maps."
+}
diff --git a/games-rpg/eternal-lands-bloodsucker/metadata.xml b/games-rpg/eternal-lands-bloodsucker/metadata.xml
new file mode 100644
index 000000000000..3c1375215bd6
--- /dev/null
+++ b/games-rpg/eternal-lands-bloodsucker/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+<maintainer>
+ <email>rich0@gentoo.org</email>
+ <name>Rich Freeman</name>
+</maintainer>
+<longdescription>The Bloodsucker Maps are an add-on for Eternal Lands and provide enhanced non-official maps for the game.</longdescription>
+</pkgmetadata>