summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2016-10-15 05:11:21 -0500
committerAustin English <wizardedit@gentoo.org>2016-10-15 05:16:39 -0500
commita533bb32b21779478a403c742d1913818d6098d8 (patch)
treeff7d0d41037b33fabc153f51d49f88888f509467 /games-rpg/gwiz/gwiz-0.8-r1.ebuild
parentgames-rpg/freedroidrpg: remove deprecated games eclass (diff)
downloadgentoo-a533bb32b21779478a403c742d1913818d6098d8.tar.gz
gentoo-a533bb32b21779478a403c742d1913818d6098d8.tar.bz2
gentoo-a533bb32b21779478a403c742d1913818d6098d8.zip
games-rpg/gwiz: remove deprecated games eclass
Also update to EAPI 6 Gentoo-Bug: https://bugs.gentoo.org/574082 Package-Manager: portage-2.3.0
Diffstat (limited to 'games-rpg/gwiz/gwiz-0.8-r1.ebuild')
-rw-r--r--games-rpg/gwiz/gwiz-0.8-r1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/games-rpg/gwiz/gwiz-0.8-r1.ebuild b/games-rpg/gwiz/gwiz-0.8-r1.ebuild
new file mode 100644
index 000000000000..01b725cbda58
--- /dev/null
+++ b/games-rpg/gwiz/gwiz-0.8-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit eutils flag-o-matic
+
+DESCRIPTION="clone of old-school Wizardry(tm) games by SirTech"
+HOMEPAGE="http://icculus.org/gwiz/"
+SRC_URI="http://icculus.org/gwiz/${P}.tar.bz2"
+
+KEYWORDS="~alpha ~amd64 ~ppc ~x86"
+SLOT="0"
+LICENSE="GPL-2"
+IUSE=""
+
+DEPEND=">=media-libs/libsdl-1.2.3[joystick,video]
+ >=media-libs/sdl-image-1.2.1-r1[png]
+ >=media-libs/sdl-ttf-2.0.4"
+RDEPEND=${DEPEND}
+
+PATCHES=(
+ "${FILESDIR}"/${P}-buffer.patch
+)
+
+src_prepare() {
+ default
+
+ append-cflags -std=gnu89 # build with gcc5 (bug #572532)
+}
+
+src_install() {
+ DOCS="AUTHORS ChangeLog README doc/HOWTO-PLAY" \
+ default
+ newicon pixmaps/gwiz_icon.xpm ${PN}.xpm
+ make_desktop_entry gwiz Gwiz
+}