summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-rpg/lure/lure-1.1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-rpg/lure/lure-1.1.ebuild')
-rw-r--r--games-rpg/lure/lure-1.1.ebuild109
1 files changed, 109 insertions, 0 deletions
diff --git a/games-rpg/lure/lure-1.1.ebuild b/games-rpg/lure/lure-1.1.ebuild
new file mode 100644
index 000000000000..1ccdc406214b
--- /dev/null
+++ b/games-rpg/lure/lure-1.1.ebuild
@@ -0,0 +1,109 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils games
+
+DAT_PV=0.13.1
+DESCRIPTION="Lure of the Temptress"
+HOMEPAGE="http://www.revolution.co.uk/_display.php?id=10"
+SRC_URI="
+ http://scummvm.svn.sourceforge.net/svnroot/scummvm/scummvm/tags/release-0-13-1/dists/engine-data/lure.dat -> lure-${DAT_PV}.dat
+ !linguas_en? ( !linguas_es? ( !linguas_fr? ( !linguas_de? ( !linguas_it?
+ ( mirror://sourceforge/scummvm/${P}.zip -> ${PN}-en-${PV}.zip ) ) ) ) )
+ linguas_en? ( mirror://sourceforge/scummvm/${P}.zip -> ${PN}-en-${PV}.zip )
+ linguas_es? ( mirror://sourceforge/scummvm/${PN}-es-${PV}.zip )
+ linguas_fr? ( mirror://sourceforge/scummvm/${PN}-fr-${PV}.zip )
+ linguas_de? ( mirror://sourceforge/scummvm/${PN}-de-${PV}.zip )
+ linguas_it? ( mirror://sourceforge/scummvm/${PN}-it-${PV}.zip )"
+
+LICENSE="lure"
+SLOT="0"
+KEYWORDS="amd64 x86"
+LANGS_IUSE="linguas_en linguas_es linguas_de linguas_fr linguas_it"
+IUSE=${LANGS_IUSE}
+RESTRICT="mirror"
+
+RDEPEND=">=games-engines/scummvm-0.13.1"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S=${WORKDIR}
+
+any_linguas() {
+ use linguas_en || use linguas_es || use linguas_de || use linguas_fr || use linguas_it
+}
+
+src_unpack() {
+ local lang
+
+ if any_linguas ; then
+ for lang in ${LANGS_IUSE}
+ do
+ use ${lang} && unpack ${PN}-${lang/linguas_}-${PV}.zip
+ done
+ mv lure lure-en 2> /dev/null
+ else
+ unpack ${PN}-en-${PV}.zip
+ fi
+}
+
+src_prepare() {
+ local lang f
+
+ find . \
+ \( -iname "*exe" \
+ -o -iname "*ega" \
+ -o -iname LICENSE.txt \) \
+ -exec rm -f '{}' +
+ mkdir docs
+ if any_linguas ; then
+ for lang in ${LANGS_IUSE}
+ do
+ mkdir docs/${lang}
+ find lure-${lang/linguas_} \
+ \( -iname "*pdf" \
+ -o -iname README \
+ -o -iname "*txt" \) \
+ -exec mv '{}' docs/${lang} \; 2> /dev/null
+ done
+ else
+ find lure \
+ \( -iname "*pdf" \
+ -o -iname README \
+ -o -iname "*txt" \) \
+ -exec mv '{}' docs \; 2> /dev/null
+ fi
+ for f in $(find docs -type f)
+ do
+ mv ${f} ${f%.*}.$(echo ${f#*.} | tr '[[:upper:]]' '[[:lower:]]') 2> /dev/null
+ done
+}
+
+src_install() {
+ local lang
+
+ if any_linguas ; then
+ for lang in ${LANGS_IUSE}
+ do
+ if use ${lang} ; then
+ lang=${lang/linguas_}
+ insinto "${GAMES_DATADIR}"/${PN}-${lang}
+ newins "${DISTDIR}"/lure-${DAT_PV}.dat lure.dat
+ doins -r ${PN}-${lang}/*
+ games_make_wrapper ${PN}-${lang} "scummvm -q ${lang} -f -p \"${GAMES_DATADIR}/${PN}-${lang}\" lure" .
+ make_desktop_entry ${PN}-${lang} "Lure of the Temptress (${lang})" ${PN}
+ docinto linguas_${lang}
+ dodoc docs/linguas_${lang}/*
+ fi
+ done
+ else
+ insinto "${GAMES_DATADIR}"/${PN}
+ newins "${DISTDIR}"/lure-${DAT_PV}.dat lure.dat
+ doins -r ${PN}/*
+ games_make_wrapper ${PN} "scummvm -f -p \"${GAMES_DATADIR}/${PN}\" lure" .
+ make_desktop_entry ${PN} "Lure of the Temptress"
+ fi
+ prepgamesdirs
+}