summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-01-04 03:05:36 -0500
committerIonen Wolkens <ionen@gentoo.org>2022-01-04 03:05:36 -0500
commita9feb245fd39409c298667d1b14dc2fc6d4019ee (patch)
treef7acc1a0e2557513223f7ade82376be8490da91a /games-rpg/openglad
parentx11-terms/kitty: sync live (diff)
downloadgentoo-a9feb245fd39409c298667d1b14dc2fc6d4019ee.tar.gz
gentoo-a9feb245fd39409c298667d1b14dc2fc6d4019ee.tar.bz2
gentoo-a9feb245fd39409c298667d1b14dc2fc6d4019ee.zip
games-rpg/openglad: fix build with clang
Closes: https://bugs.gentoo.org/830571 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'games-rpg/openglad')
-rw-r--r--games-rpg/openglad/files/openglad-0.98_p20200907-clang.patch10
-rw-r--r--games-rpg/openglad/openglad-0.98_p20200907.ebuild6
2 files changed, 15 insertions, 1 deletions
diff --git a/games-rpg/openglad/files/openglad-0.98_p20200907-clang.patch b/games-rpg/openglad/files/openglad-0.98_p20200907-clang.patch
new file mode 100644
index 000000000000..056521c604fb
--- /dev/null
+++ b/games-rpg/openglad/files/openglad-0.98_p20200907-clang.patch
@@ -0,0 +1,10 @@
+Option gets used for C as well leading to gcc warnings and a hard
+error with clang. Option isn't actually needed, so just remove it.
+
+https://bugs.gentoo.org/830571
+--- a/premake4.lua
++++ b/premake4.lua
+@@ -47,3 +47,2 @@
+ defines { "PHYSFS_SUPPORTS_ZIP" }
+- buildoptions { "-std=gnu++0x" }
+
diff --git a/games-rpg/openglad/openglad-0.98_p20200907.ebuild b/games-rpg/openglad/openglad-0.98_p20200907.ebuild
index 33e42ea2dcea..e48eaeb991a6 100644
--- a/games-rpg/openglad/openglad-0.98_p20200907.ebuild
+++ b/games-rpg/openglad/openglad-0.98_p20200907.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -29,6 +29,10 @@ BDEPEND="
dev-util/premake:5
virtual/pkgconfig"
+PATCHES=(
+ "${FILESDIR}"/${P}-clang.patch
+)
+
src_prepare() {
default