summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-rpg/sacred-gold/sacred-gold-1.0.01.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-rpg/sacred-gold/sacred-gold-1.0.01.ebuild')
-rw-r--r--games-rpg/sacred-gold/sacred-gold-1.0.01.ebuild63
1 files changed, 63 insertions, 0 deletions
diff --git a/games-rpg/sacred-gold/sacred-gold-1.0.01.ebuild b/games-rpg/sacred-gold/sacred-gold-1.0.01.ebuild
new file mode 100644
index 000000000000..41389e0bdf25
--- /dev/null
+++ b/games-rpg/sacred-gold/sacred-gold-1.0.01.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit versionator eutils cdrom unpacker games
+
+PV_MAJOR=$(get_version_component_range 1-2)
+MY_P=sacred-${PV_MAJOR}-${PV}
+
+DESCRIPTION="Action role-playing game"
+HOMEPAGE="http://linuxgamepublishing.com/info.php?id=sacred"
+SRC_URI="http://updatefiles.linuxgamepublishing.com/sacred/${MY_P}-x86.run"
+
+LICENSE="all-rights-reserved GPL-2 LGPL-2"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE=""
+RESTRICT="mirror bindist strip"
+
+RDEPEND="
+ x11-libs/libX11[abi_x86_32(-)]
+ x11-libs/libXext[abi_x86_32(-)]
+ x11-libs/libXi[abi_x86_32(-)]
+ virtual/opengl[abi_x86_32(-)]
+"
+DEPEND=""
+
+S=${WORKDIR}
+
+src_unpack() {
+ cdrom_get_cds .data/bin/Linux/x86/sacred
+ ln -sfn "${CDROM_ROOT}"/.data cd
+ unpack ./cd/data/data.tar.gz
+ rm -f cd
+ cp -f "${CDROM_ROOT}"/.data/bin/Linux/x86/sacred* . || die
+ cp -f "${CDROM_ROOT}"/README* . || die
+ cp -f "${CDROM_ROOT}"/manual.pdf . || die
+
+ mkdir -p "patch"
+ cd "patch"
+ unpack_makeself ${MY_P}-x86.run
+ bin/Linux/x86/loki_patch patch.dat "${S}" || die "loki_patch failed"
+ cd "${S}"
+ rm -rf "patch"
+
+ mv lib/lib{1,2}/* lib
+ rmdir lib/lib{1,2}
+}
+
+src_install() {
+ dir=${GAMES_PREFIX_OPT}/${PN}
+
+ insinto "${dir}"
+ mv * "${D}/${dir}" || die
+
+ games_make_wrapper ${PN} ./sacred "${dir}" "${dir}"/lib
+ newicon "${CDROM_ROOT}"/.data/icon.xpm ${PN}.xpm
+ make_desktop_entry ${PN} "Sacred - Gold" ${PN}
+
+ prepgamesdirs
+}