summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2021-07-17 22:55:58 -0400
committerIonen Wolkens <ionen@gentoo.org>2021-07-18 01:14:51 -0400
commit02cab29b975182c755dc885ab8bf7001b0d84a8f (patch)
tree51387b823e0eb26adfc23e18ff31450fc3ba2b39 /games-rpg
parentgames-rpg/pcgen: add github remote-id (diff)
downloadgentoo-02cab29b975182c755dc885ab8bf7001b0d84a8f.tar.gz
gentoo-02cab29b975182c755dc885ab8bf7001b0d84a8f.tar.bz2
gentoo-02cab29b975182c755dc885ab8bf7001b0d84a8f.zip
games-rpg/pcgen: add 6.06.01
Technically 6.08.00_rc8 is the current stable per upstream website (despite _rc8 as it appears final with development shifted to 6.10), but requires masked virtual/jre-11. Adding previous stable meanwhile. Could use more work and building from source, but that needs Gradle. Moved files to /opt from /usr/share due to being prebuilt. Closes: https://bugs.gentoo.org/611908 Closes: https://bugs.gentoo.org/672972 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'games-rpg')
-rw-r--r--games-rpg/pcgen/Manifest1
-rw-r--r--games-rpg/pcgen/pcgen-6.06.01.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/games-rpg/pcgen/Manifest b/games-rpg/pcgen/Manifest
index 38926b7852b0..6902226246ad 100644
--- a/games-rpg/pcgen/Manifest
+++ b/games-rpg/pcgen/Manifest
@@ -1 +1,2 @@
DIST pcgen-6.04.01-full.zip 68679438 BLAKE2B e9afa6b9937804988425d8d18cfed7728197ecc303f586ed899491e4d500eb0e6ddc0ae92aef1d4bfef7ff3fb987cca34af95246c83ebe71e089e3e5e91aa9dd SHA512 37e76e9bca3defe803459f898d3c51015cb4c4f69905c4179b78b1b26977b7d720ef413b3f5b2ef4252aa98f732075b9567c4f4822c61d169a5a0a6e2c78c0d4
+DIST pcgen-6.06.01-full.zip 73423642 BLAKE2B 54dbebb3e73188435ce6ed6d38387e194fff156f39d9238b55f0e7d990f785eb79f562a41c60a4861f637514615802ef5103f886e0f96624f7f53b197adcd5a3 SHA512 9af94aa434229ce00f08385759b4efc22f16ad32be81be4177c44eec94f1bedcec0742b494bbed3c95c1bcf9b2c51e2649330ee0a54f7ca4b0042966099851eb
diff --git a/games-rpg/pcgen/pcgen-6.06.01.ebuild b/games-rpg/pcgen/pcgen-6.06.01.ebuild
new file mode 100644
index 000000000000..6bf03db1d130
--- /dev/null
+++ b/games-rpg/pcgen/pcgen-6.06.01.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop edos2unix
+
+DESCRIPTION="D&D character generator"
+HOMEPAGE="http://pcgen.org/"
+SRC_URI="https://github.com/PCGen/pcgen/releases/download/${PV}/${P}-full.zip"
+S="${WORKDIR}/${PN}"
+
+LICENSE="LGPL-2.1 OGL-1.0a"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=virtual/jre-1.8:*"
+BDEPEND="app-arch/unzip"
+
+src_prepare() {
+ default
+
+ edos2unix ${PN}.sh
+ sed "/^cd /c\\cd \"${EPREFIX}/opt/${PN}\" || exit 1" ${PN}.sh > "${T}"/${PN} || die
+
+ rm -r LICENSE docs/{doc_tools,pngcrush_logs.txt} ${PN}.{exe,sh} || die
+}
+
+src_install() {
+ dobin "${T}"/${PN}
+
+ insinto /opt/${PN}
+ doins -r .
+
+ newicon system/sponsors/pcgen/pcgen_128x128.png ${PN}.png
+ make_desktop_entry ${PN} PCGen
+}