summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2016-10-15 06:06:43 -0500
committerAustin English <wizardedit@gentoo.org>2016-10-15 06:08:15 -0500
commit69812ecdaab8a173d69ba4c316fb8f07b58312b4 (patch)
treeaf1b25664f6f08f3f7aca08452d5556e47d85f7e /games-rpg
parentgames-rpg/openglad: remove deprecated games eclass (diff)
downloadgentoo-69812ecdaab8a173d69ba4c316fb8f07b58312b4.tar.gz
gentoo-69812ecdaab8a173d69ba4c316fb8f07b58312b4.tar.bz2
gentoo-69812ecdaab8a173d69ba4c316fb8f07b58312b4.zip
games-rpg/pcgen: remove deprecated games eclass
Also update to EAPI 6 Gentoo-Bug: https://bugs.gentoo.org/574082 Package-Manager: portage-2.3.0
Diffstat (limited to 'games-rpg')
-rw-r--r--games-rpg/pcgen/pcgen-6.04.01-r1.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/games-rpg/pcgen/pcgen-6.04.01-r1.ebuild b/games-rpg/pcgen/pcgen-6.04.01-r1.ebuild
new file mode 100644
index 000000000000..f0190535e62f
--- /dev/null
+++ b/games-rpg/pcgen/pcgen-6.04.01-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit gnome2-utils
+
+DESCRIPTION="D&D character generator"
+HOMEPAGE="http://pcgen.sourceforge.net/"
+SRC_URI="mirror://sourceforge/pcgen/${P}-full.zip"
+
+LICENSE="LGPL-2.1 OGL-1.0a"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=virtual/jre-1.6"
+DEPEND="app-arch/unzip"
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ default
+
+ rm -vf *.bat || die
+ sed "/dirname/ c\cd \"\/usr\/share\/${PN}\"" pcgen.sh > "${T}"/${PN} || die
+}
+
+src_install() {
+ dobin "${T}"/${PN}
+ insinto /usr/share/${PN}
+ doins -r *
+ newicon -s 128 system/sponsors/pcgen/pcgen_128x128.png ${PN}.png
+ make_desktop_entry ${PN} PCGen
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}