summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2021-06-26 19:56:07 +0200
committerIonen Wolkens <ionen@gentoo.org>2021-07-05 18:51:54 -0400
commit82b15e09430e7c3dbcba73b458175429d0852d34 (patch)
tree8103110ddd340c3c8f074296b5694781053d00c3 /games-rpg
parentgames-rpg/dreamweb: EAPI8, ebuild improvements (diff)
downloadgentoo-82b15e09430e7c3dbcba73b458175429d0852d34.tar.gz
gentoo-82b15e09430e7c3dbcba73b458175429d0852d34.tar.bz2
gentoo-82b15e09430e7c3dbcba73b458175429d0852d34.zip
games-rpg/gwiz: EAPI8, ebuild improvements
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'games-rpg')
-rw-r--r--games-rpg/gwiz/gwiz-0.8-r1.ebuild30
1 files changed, 16 insertions, 14 deletions
diff --git a/games-rpg/gwiz/gwiz-0.8-r1.ebuild b/games-rpg/gwiz/gwiz-0.8-r1.ebuild
index f7a462a9a302..d8d166f528bb 100644
--- a/games-rpg/gwiz/gwiz-0.8-r1.ebuild
+++ b/games-rpg/gwiz/gwiz-0.8-r1.ebuild
@@ -1,22 +1,22 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-inherit eutils flag-o-matic
+EAPI=8
-DESCRIPTION="clone of old-school Wizardry(tm) games by SirTech"
-HOMEPAGE="http://icculus.org/gwiz/"
-SRC_URI="http://icculus.org/gwiz/${P}.tar.bz2"
+inherit desktop flag-o-matic toolchain-funcs
+
+DESCRIPTION="Clone of old-school Wizardry(tm) games by SirTech"
+HOMEPAGE="https://icculus.org/gwiz/"
+SRC_URI="https://icculus.org/gwiz/${P}.tar.bz2"
KEYWORDS="~alpha ~amd64 ~x86"
SLOT="0"
-LICENSE="GPL-2"
-IUSE=""
+LICENSE="GPL-2+"
-DEPEND=">=media-libs/libsdl-1.2.3[joystick,video]
- >=media-libs/sdl-image-1.2.1-r1[png]
- >=media-libs/sdl-ttf-2.0.4"
-RDEPEND=${DEPEND}
+DEPEND="media-libs/libsdl[joystick,video]
+ media-libs/sdl-image[png]
+ media-libs/sdl-ttf"
+RDEPEND="${DEPEND}"
PATCHES=(
"${FILESDIR}"/${P}-buffer.patch
@@ -25,12 +25,14 @@ PATCHES=(
src_prepare() {
default
+ tc-export CC
append-cflags -std=gnu89 # build with gcc5 (bug #572532)
}
src_install() {
- DOCS="AUTHORS ChangeLog README doc/HOWTO-PLAY" \
- default
+ default
+
+ dodoc doc/HOWTO-PLAY
newicon pixmaps/gwiz_icon.xpm ${PN}.xpm
make_desktop_entry gwiz Gwiz
}