summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFinn Rayment <finn@rayment.fr>2022-12-24 22:52:36 +1100
committerViorel Munteanu <ceamac@gentoo.org>2022-12-24 14:27:05 +0200
commit95d3035cf0bbd889225fea79c9a659e48f9523ae (patch)
tree209b93b5644b78770b867e24d1dff7a2055ae2b5 /games-rpg
parentgames-rpg/baldurs-gate-ee: Dropped 2.3.67.3-r1 (diff)
downloadgentoo-95d3035cf0bbd889225fea79c9a659e48f9523ae.tar.gz
gentoo-95d3035cf0bbd889225fea79c9a659e48f9523ae.tar.bz2
gentoo-95d3035cf0bbd889225fea79c9a659e48f9523ae.zip
games-rpg/baldurs-gate-ee: Added 2.6.6.0.47291
And fixed metadata link. Signed-off-by: Finn Rayment <finn@rayment.fr> Closes: https://github.com/gentoo/gentoo/pull/28636 Signed-off-by: Viorel Munteanu <ceamac@gentoo.org>
Diffstat (limited to 'games-rpg')
-rw-r--r--games-rpg/baldurs-gate-ee/Manifest2
-rw-r--r--games-rpg/baldurs-gate-ee/baldurs-gate-ee-2.6.6.0.47291.ebuild52
-rw-r--r--games-rpg/baldurs-gate-ee/metadata.xml2
3 files changed, 54 insertions, 2 deletions
diff --git a/games-rpg/baldurs-gate-ee/Manifest b/games-rpg/baldurs-gate-ee/Manifest
index 80b6b655273c..89583ffbc452 100644
--- a/games-rpg/baldurs-gate-ee/Manifest
+++ b/games-rpg/baldurs-gate-ee/Manifest
@@ -1,2 +1,2 @@
DIST baldur_s_gate_enhanced_edition_en_2_5_23121.sh 2892168067 BLAKE2B 7e20922f539be65cf7371f7f1706873e5a147313e3aa0335bfa5d6c4456a40665260a36abab6e73361c5f9c0a0bc2faff6e719dd72fb0ddd8b0e1c22d6eaedd8 SHA512 b5b84148b35984109454e1299ee29d287750172e617fb97e65c46b2c9419173348b37d54587bd44a3eacb6380c9b13e4be91af5625009cba797843483be7165d
-DIST gog_baldur_s_gate_enhanced_edition_2.5.0.9.sh 2877124067 BLAKE2B 244e93ae089703c9fae3dcfcad4fb9c1eb32695e7288f7a05b3f2996887f90d6912e745e9b47a93ba45ee3ddda8363e69d22e62c57258ee54c24c47f07b2f619 SHA512 56d4796a959658f29cabef6e7339db5ba9fa792d9fd899ebc375c9b5cf94305b6d11c21d41a8809fcb1cbe38ecb4bc7152158ef19c87395374ab9060f48756a6
+DIST baldur_s_gate_enhanced_edition_2_6_6_0_47291.sh 2905865862 BLAKE2B 7d9dbe026ea2cab5dd96b0c190ea5f0e07385ea8bc57d475fe59528c0d73a4b244dcf6a2ee927f3491da00a91893be34ea53dcf0d63c96d95a111bc4d90c25d5 SHA512 70f1cd7365b2053cd175792327e006917236058fe8e473a1e9d76fb3a25f04fc2fc34d1a1776bb6ab3277b9e07153682bce463ef61f7739e32eb16e35c641a3b
diff --git a/games-rpg/baldurs-gate-ee/baldurs-gate-ee-2.6.6.0.47291.ebuild b/games-rpg/baldurs-gate-ee/baldurs-gate-ee-2.6.6.0.47291.ebuild
new file mode 100644
index 000000000000..4816809b6c38
--- /dev/null
+++ b/games-rpg/baldurs-gate-ee/baldurs-gate-ee-2.6.6.0.47291.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop unpacker wrapper
+
+DESCRIPTION="Baldur's Gate: Enhanced Edition"
+HOMEPAGE="https://baldursgate.beamdog.com/"
+SRC_URI="baldur_s_gate_enhanced_edition_${PV//./_}.sh"
+
+LICENSE="GOG-EULA"
+SLOT="0"
+KEYWORDS="-* ~amd64"
+RESTRICT="bindist fetch"
+
+RDEPEND="dev-libs/expat
+ dev-libs/openssl-compat
+ media-libs/openal
+ virtual/opengl
+ x11-libs/libX11"
+BDEPEND="app-arch/unzip"
+
+QA_PRESTRIPPED="opt/${PN}/BaldursGate"
+
+S="${WORKDIR}/data/noarch"
+
+pkg_nofetch() {
+ einfo "Please buy and download \"${SRC_URI}\" from"
+ einfo "https://www.gog.com/game/baldurs_gate_enhanced_edition"
+ einfo "and place it in your DISTDIR directory."
+}
+
+src_unpack() {
+ unpack_zip ${A}
+}
+
+src_install() {
+ local dir="/opt/${PN}"
+
+ dodoc -r "game/Manuals/."
+ rm -r "game/Manuals" || die "rm failed"
+
+ insinto "${dir}"
+ doins -r "game/."
+ fperms +x "${dir}/BaldursGate"
+
+ make_wrapper ${PN} "./BaldursGate" "${dir}"
+
+ newicon "support/icon.png" "${PN}.png"
+ make_desktop_entry "${PN}" "Baldur's Gate: Enhanced Edition" "${PN}"
+}
diff --git a/games-rpg/baldurs-gate-ee/metadata.xml b/games-rpg/baldurs-gate-ee/metadata.xml
index f4eb16164ba7..2ff87d46c74f 100644
--- a/games-rpg/baldurs-gate-ee/metadata.xml
+++ b/games-rpg/baldurs-gate-ee/metadata.xml
@@ -9,6 +9,6 @@
Dungeons &amp; Dragons (AD&amp;D) 2nd edition rules.
</longdescription>
<upstream>
- <bugs-to>https://support.baldursgate.com/projects/bg-ee-bugs/issues</bugs-to>
+ <bugs-to>https://beamdog.atlassian.net/servicedesk/customer/portals</bugs-to>
</upstream>
</pkgmetadata>