summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-11-16 13:17:18 -0500
committerIonen Wolkens <ionen@gentoo.org>2022-11-16 13:56:30 -0500
commita91b1688b42abf36121c4e81c6135ce1d6f85c18 (patch)
treef3f088d22f38771676bcd96b50c123e5a4f50eda /games-rpg
parentgames-rpg/freedroidrpg: update upstream metadata with codeberg (diff)
downloadgentoo-a91b1688b42abf36121c4e81c6135ce1d6f85c18.tar.gz
gentoo-a91b1688b42abf36121c4e81c6135ce1d6f85c18.tar.bz2
gentoo-a91b1688b42abf36121c4e81c6135ce1d6f85c18.zip
games-rpg/freedroidrpg: add 1.0_rc3
Unsurprisingly, the third issues is still unresolved wrt #729326 Bug: https://bugs.gentoo.org/729326 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'games-rpg')
-rw-r--r--games-rpg/freedroidrpg/Manifest1
-rw-r--r--games-rpg/freedroidrpg/freedroidrpg-1.0_rc3.ebuild73
2 files changed, 74 insertions, 0 deletions
diff --git a/games-rpg/freedroidrpg/Manifest b/games-rpg/freedroidrpg/Manifest
index f45a284875b8..8d38b9e3f491 100644
--- a/games-rpg/freedroidrpg/Manifest
+++ b/games-rpg/freedroidrpg/Manifest
@@ -1 +1,2 @@
DIST freedroidRPG-1.0rc2.tar.gz 233852127 BLAKE2B c87c2314d17037873acf4fc24ce20790c9ec40c8f7b1ea27e6ab9c543abb671bc50b3ff5b86900f7111d1f1a899213dcb90529d2e39918801c9cc3a42585f02e SHA512 a79afdb089691dd59b0128f34f7068c69fac8c057a0485bca3275f4914b1c9c0f21cbb9102ecdc99911b70456c078dbdeb8981fd7714836cd9535677bcc4d1e7
+DIST freedroidRPG-1.0rc3.tar.gz 237674000 BLAKE2B 44031686ccd9af3bb082ec9cd2bf233792d2b1019a35b0fc2585df39a05b678ef784f9ff5861fbbcfe7ea624a338f6ab28f855158b7c1d18d52fa9e410410d7d SHA512 51125619fb57f8cb16746b3ff100175ab7917c567c8b1efcbc1aebc80a4774501a934b2fd544d65f1420212f9043015c2b88f08d785e765a30ce478157d887fd
diff --git a/games-rpg/freedroidrpg/freedroidrpg-1.0_rc3.ebuild b/games-rpg/freedroidrpg/freedroidrpg-1.0_rc3.ebuild
new file mode 100644
index 000000000000..680b0d7e6349
--- /dev/null
+++ b/games-rpg/freedroidrpg/freedroidrpg-1.0_rc3.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+LUA_COMPAT=( lua5-3 )
+PYTHON_COMPAT=( python3_{8..11} )
+inherit lua-single python-any-r1 xdg
+
+MY_PV=$(ver_rs 2 '')
+
+DESCRIPTION="Modification of the classical Freedroid engine into an RPG"
+HOMEPAGE="https://www.freedroid.org/"
+SRC_URI="https://ftp.osuosl.org/pub/freedroid/freedroidRPG-$(ver_cut 1-2)/freedroidRPG-${MY_PV}.tar.gz"
+S="${WORKDIR}/${PN}-${MY_PV^^}"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="debug devtools opengl profile +sound"
+REQUIRED_USE="${LUA_REQUIRED_USE}"
+
+RDEPEND="
+ ${LUA_DEPS}
+ media-libs/libjpeg-turbo
+ media-libs/libpng:=
+ media-libs/libsdl[opengl?,sound?,video]
+ media-libs/sdl-gfx:=
+ media-libs/sdl-image[jpeg,png]
+ sys-libs/zlib:=
+ virtual/libintl
+ devtools? ( media-libs/sdl-ttf )
+ opengl? (
+ media-libs/glew:0=
+ virtual/opengl
+ )
+ sound? (
+ media-libs/libogg
+ media-libs/libvorbis
+ media-libs/sdl-mixer[vorbis]
+ )"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ ${PYTHON_DEPS}
+ sys-devel/gettext
+ virtual/awk
+ virtual/pkgconfig"
+
+pkg_setup() {
+ lua-single_pkg_setup
+ python-any-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+
+ python_fix_shebang src/gen_savestruct.py # build only
+ rm data/sound/speak.py || die # unused, skip install / python rdep
+}
+
+src_configure() {
+ local econfargs=(
+ $(use_enable debug backtrace)
+ $(use_enable debug)
+ $(use_enable devtools dev-tools)
+ $(use_enable opengl)
+ $(use_enable profile rtprof)
+ $(use_enable sound)
+ $(use_with debug extra-warnings)
+ )
+
+ econf "${econfargs[@]}"
+}