summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2016-01-30 03:42:04 -0500
committerMichael Sterrett <mr_bones_@gentoo.org>2016-01-30 03:42:45 -0500
commitac06b9ed615f35d75f92f8aad7666a528acf123c (patch)
tree72bab464c90b479722a62d0c19f6bcccbde98e73 /games-rpg
parentmedia-gfx/graphite2: fix function call (diff)
downloadgentoo-ac06b9ed615f35d75f92f8aad7666a528acf123c.tar.gz
gentoo-ac06b9ed615f35d75f92f8aad7666a528acf123c.tar.bz2
gentoo-ac06b9ed615f35d75f92f8aad7666a528acf123c.zip
games-rpg/manaplus: version bump
Package-Manager: portage-2.2.26
Diffstat (limited to 'games-rpg')
-rw-r--r--games-rpg/manaplus/Manifest1
-rw-r--r--games-rpg/manaplus/manaplus-1.6.1.16.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/games-rpg/manaplus/Manifest b/games-rpg/manaplus/Manifest
index 2f298b823a8d..8407e27acd67 100644
--- a/games-rpg/manaplus/Manifest
+++ b/games-rpg/manaplus/Manifest
@@ -1,2 +1,3 @@
DIST manaplus-1.5.11.21.tar.xz 9556540 SHA256 57b6e0d8a730f56060062aa0d6e6baafc100860aa2cc4ba5120d21772410aae6 SHA512 145479b9b6912064356f842910c2a5bbb16bacc7372b898d98f237514722bbac4c6f3fe49ee30942b6e38820cfe9d3508ba5ac64b858a6003e27569327729d7d WHIRLPOOL 628009c082219c63f42892881060dff3784ae419d3d6dab95357272774d0d0545a97cf0d7190157e3338ac38e7f821fe9e3a893f24ee10be71ec6ac83c097722
DIST manaplus-1.5.12.19.tar.xz 9581180 SHA256 8b28cbb1f385124411f4d7c2dc7066b0c0226d9afa905401ebf79c90c4e5aa69 SHA512 afbf40c22f93a2ff7720cacebfeb90ea6669061ba5bab2f45a78bd11b890ca516606b6d260903eaa04b0cf0e3e49dce9301c030de50ffceeb70329d1284e0369 WHIRLPOOL 2fcf321101d6178942db6f51bbd38f88d6423f097ae8fd0d6415d5df2096dbd10e188e008166e57fb3f359edc9c1315dcfad78b546ba8804dabe9984cd00a066
+DIST manaplus-1.6.1.16.tar.xz 9610164 SHA256 393678d7de6d0253e53756bb689d2f778ed4c402215c8d72c576fdb6da963aef SHA512 2ba77b8d79e765cad7ecf3074eec49791a3f68d4fa66eed9bbf13adf23e94c35b55d8587850352e0855a7320c828dc886224fa4aa6260cd449a850ba469dd0be WHIRLPOOL f7dfdb3a0693f55d2202f488f0bfd036cb23f821c14962105c73ea16c5969f0c7bd53e2d5abd416f5d588be73de461bc1d58ff9269ed4c55cd4064644a759805
diff --git a/games-rpg/manaplus/manaplus-1.6.1.16.ebuild b/games-rpg/manaplus/manaplus-1.6.1.16.ebuild
new file mode 100644
index 000000000000..193b66eeb7f0
--- /dev/null
+++ b/games-rpg/manaplus/manaplus-1.6.1.16.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit games
+
+DESCRIPTION="OpenSource 2D MMORPG client for Evol Online and The Mana World"
+HOMEPAGE="http://manaplus.evolonline.org"
+SRC_URI="http://download.evolonline.org/manaplus/download/${PV}/manaplus-${PV}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls opengl"
+
+RDEPEND="
+ >=dev-games/physfs-1.0.0
+ dev-libs/libxml2
+ media-libs/libpng:0=
+ media-libs/libsdl2[X,opengl?,video]
+ media-libs/sdl2-gfx
+ media-libs/sdl2-image[png]
+ media-libs/sdl2-mixer[vorbis]
+ media-libs/sdl2-net
+ media-libs/sdl2-ttf
+ net-misc/curl
+ sys-libs/zlib
+ x11-libs/libX11
+ x11-misc/xdg-utils
+ x11-apps/xmessage
+ media-fonts/dejavu
+ media-fonts/wqy-microhei
+ media-fonts/liberation-fonts
+ media-fonts/mplus-outline-fonts
+ nls? ( virtual/libintl )
+ opengl? ( virtual/opengl )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+src_configure() {
+ CONFIG_SHELL=/bin/bash \
+ egamesconf \
+ --with-sdl2 \
+ --without-internalsdlgfx \
+ --localedir=/usr/share/locale \
+ --prefix="/usr" \
+ --bindir="${GAMES_BINDIR}" \
+ $(use_with opengl) \
+ $(use_enable nls)
+}
+
+src_install() {
+ default
+ dosym /usr/share/fonts/dejavu/DejaVuSans-Bold.ttf "${GAMES_DATADIR}"/${PN}/data/fonts/dejavusans-bold.ttf
+ dosym /usr/share/fonts/dejavu/DejaVuSans.ttf "${GAMES_DATADIR}"/${PN}/data/fonts/dejavusans.ttf
+ dosym /usr/share/fonts/dejavu/DejaVuSansMono-Bold.ttf "${GAMES_DATADIR}"/${PN}/data/fonts/dejavusansmono-bold.ttf
+ dosym /usr/share/fonts/dejavu/DejaVuSansMono.ttf "${GAMES_DATADIR}"/${PN}/data/fonts/dejavusansmono.ttf
+ dosym /usr/share/fonts/dejavu/DejaVuSerifCondensed-Bold.ttf "${GAMES_DATADIR}"/${PN}/data/fonts/dejavuserifcondensed-bold.ttf
+ dosym /usr/share/fonts/dejavu/DejaVuSerifCondensed.ttf "${GAMES_DATADIR}"/${PN}/data/fonts/dejavuserifcondensed.ttf
+ dosym /usr/share/fonts/liberation-fonts/LiberationMono-Bold.ttf "${GAMES_DATADIR}"/${PN}/data/fonts/liberationsansmono-bold.ttf
+ dosym /usr/share/fonts/liberation-fonts/LiberationMono-Regular.ttf "${GAMES_DATADIR}"/${PN}/data/fonts/liberationsansmono.ttf
+ dosym /usr/share/fonts/liberation-fonts/LiberationSans-Bold.ttf "${GAMES_DATADIR}"/${PN}/data/fonts/liberationsans-bold.ttf
+ dosym /usr/share/fonts/liberation-fonts/LiberationSans-Regular.ttf "${GAMES_DATADIR}"/${PN}/data/fonts/liberationsans.ttf
+ dosym /usr/share/fonts/mplus-outline-fonts/mplus-1p-bold.ttf "${GAMES_DATADIR}"/${PN}/data/fonts/mplus-1p-bold.ttf
+ dosym /usr/share/fonts/mplus-outline-fonts/mplus-1p-regular.ttf "${GAMES_DATADIR}"/${PN}/data/fonts/mplus-1p-regular.ttf
+ dosym /usr/share/fonts/wqy-microhei/wqy-microhei.ttc "${GAMES_DATADIR}"/${PN}/data/fonts/wqy-microhei.ttf
+
+ prepgamesdirs
+}