summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2021-07-17 23:37:54 -0400
committerIonen Wolkens <ionen@gentoo.org>2021-07-18 01:14:51 -0400
commitc5b6ce931d4492e25dd8eb6ef062e576db2b8586 (patch)
tree4d93262daa8b2e95006c029e7c4754b91d4bf6f0 /games-rpg
parentgames-rpg/dear-esther: hopefully fix install, tidy a bit (diff)
downloadgentoo-c5b6ce931d4492e25dd8eb6ef062e576db2b8586.tar.gz
gentoo-c5b6ce931d4492e25dd8eb6ef062e576db2b8586.tar.bz2
gentoo-c5b6ce931d4492e25dd8eb6ef062e576db2b8586.zip
games-rpg/grimrock: EAPI 6->7, tidy a bit
Do not own this version of the game, so trying safe changes. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'games-rpg')
-rw-r--r--games-rpg/grimrock/grimrock-20150707.ebuild48
1 files changed, 22 insertions, 26 deletions
diff --git a/games-rpg/grimrock/grimrock-20150707.ebuild b/games-rpg/grimrock/grimrock-20150707.ebuild
index 03275c50c9a5..e0950dd5bc09 100644
--- a/games-rpg/grimrock/grimrock-20150707.ebuild
+++ b/games-rpg/grimrock/grimrock-20150707.ebuild
@@ -1,36 +1,35 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit desktop gnome2-utils unpacker
+inherit desktop unpacker xdg
-TIMESTAMP="${PV:0:4}-${PV:4:2}-${PV:6:2}"
MY_PN="Grimrock"
+MY_TIMESTAMP="${PV:0:4}-${PV:4:2}-${PV:6:2}"
+
DESCRIPTION="Legend of Grimrock: The ultimate dungeon crawling RPG + modding engine"
HOMEPAGE="http://www.grimrock.net/"
-SRC_URI="Grimrock-Linux-${TIMESTAMP}.sh"
+SRC_URI="Grimrock-Linux-${MY_TIMESTAMP}.sh"
+S="${WORKDIR}"
-SLOT="0"
LICENSE="all-rights-reserved"
+SLOT="0"
KEYWORDS="-* ~amd64 ~x86"
-RESTRICT="fetch bindist splitdebug"
+RESTRICT="bindist fetch"
-QA_PREBUILT="/opt/${PN}/${MY_PN}.bin"
+QA_PREBUILT="opt/${PN}/${MY_PN}.bin"
-RDEPEND="media-libs/freeimage
+RDEPEND="
+ media-libs/freeimage
media-libs/freetype:2
- media-libs/openal
media-libs/libsdl2[opengl,sound,video]
media-libs/libvorbis
+ media-libs/openal
sys-libs/zlib[minizip]
virtual/opengl
x11-libs/libX11"
-DEPEND="app-arch/xz-utils"
-
-S="${WORKDIR}"
-
pkg_nofetch() {
einfo "Please buy and download ${SRC_URI} from:"
einfo " ${HOMEPAGE}"
@@ -38,25 +37,26 @@ pkg_nofetch() {
}
src_unpack() {
- myarch=$(usex amd64 x86_64 x86)
+ MY_ARCH=$(usex amd64 x86_64 x86)
+
unpack_makeself
local i
- for i in subarch instarchive_all instarchive_linux_${myarch}; do
- ln -snf "${i}" "${i}.tar.xz" || die
- unpack ./"${i}.tar.xz"
+ for i in subarch instarchive_all instarchive_linux_${MY_ARCH}; do
+ ln -snf ${i} ${i}.tar.xz || die
+ unpack ./${i}.tar.xz
done
}
src_install() {
local dir=/opt/${PN}
- insinto "${dir}"
+ insinto ${dir}
doins ${PN}.{dat,png}
- exeinto "${dir}"
- newexe ${MY_PN}.bin{.${myarch},}
- dosym "../..${dir}"/${MY_PN}.bin /usr/bin/${PN}
+ exeinto ${dir}
+ newexe ${MY_PN}.bin{.${MY_ARCH},}
+ dosym ../..${dir}/${MY_PN}.bin /usr/bin/${PN}
doicon -s 256 ${PN}.png
newicon -s 64 ${MY_PN}.png ${PN}.png
@@ -64,7 +64,3 @@ src_install() {
dodoc README.linux
}
-
-pkg_preinst() { gnome2_icon_savelist; }
-pkg_postinst() { gnome2_icon_cache_update; }
-pkg_postrm() { gnome2_icon_cache_update; }