summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2021-06-08 13:39:54 -0400
committerIonen Wolkens <ionen@gentoo.org>2021-06-08 15:31:54 -0400
commitcdf85e47c763e8c81cafa24b1c9a0f880cd208cb (patch)
tree1e6efa6b62b5f70c13db1983d2622d034e11fd34 /games-rpg
parentgames-rpg/egoboo: add github remote-id (diff)
downloadgentoo-cdf85e47c763e8c81cafa24b1c9a0f880cd208cb.tar.gz
gentoo-cdf85e47c763e8c81cafa24b1c9a0f880cd208cb.tar.bz2
gentoo-cdf85e47c763e8c81cafa24b1c9a0f880cd208cb.zip
games-rpg/egoboo: rebase patch to drop edos2unix
edos2unix was only to accomodate a patch with wrong line terminators. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'games-rpg')
-rw-r--r--games-rpg/egoboo/egoboo-2.8.1-r1.ebuild5
-rw-r--r--games-rpg/egoboo/files/egoboo-2.8.1-gentoo.patch93
2 files changed, 38 insertions, 60 deletions
diff --git a/games-rpg/egoboo/egoboo-2.8.1-r1.ebuild b/games-rpg/egoboo/egoboo-2.8.1-r1.ebuild
index f1770edacd10..13cf1806ff65 100644
--- a/games-rpg/egoboo/egoboo-2.8.1-r1.ebuild
+++ b/games-rpg/egoboo/egoboo-2.8.1-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=6
-inherit desktop edos2unix
+inherit desktop
DESCRIPTION="A 3d dungeon crawling adventure in the spirit of NetHack"
HOMEPAGE="http://egoboo.sourceforge.net/"
@@ -29,9 +29,6 @@ PATCHES=(
)
src_prepare() {
- edos2unix src/game/platform/file_linux.c \
- src/game/network.c \
- src/game/Makefile
default
sed -i \
-e "s:@GENTOO_CONFDIR@:/etc/${PN}:" \
diff --git a/games-rpg/egoboo/files/egoboo-2.8.1-gentoo.patch b/games-rpg/egoboo/files/egoboo-2.8.1-gentoo.patch
index 2f1205a45118..36e8adf6dc73 100644
--- a/games-rpg/egoboo/files/egoboo-2.8.1-gentoo.patch
+++ b/games-rpg/egoboo/files/egoboo-2.8.1-gentoo.patch
@@ -1,56 +1,37 @@
---- a/src/game/platform/file_linux.c 2012-04-29 21:45:29.627419281 +0200
-+++ b/src/game/platform/file_linux.c 2012-04-29 21:45:29.628419211 +0200
-@@ -79,9 +79,9 @@
- strncpy( linux_dataPath, PREFIX "/share/games/egoboo-2.x", SDL_arraysize( linux_dataPath ) );
- #else
- // these are read-only directories
-- strncpy( linux_configPath, "/etc/egoboo-2.x/", SDL_arraysize( linux_configPath ) );
-+ strncpy( linux_configPath, "@GENTOO_CONFDIR@", SDL_arraysize( linux_configPath ) );
- strncpy( linux_binaryPath, "/games/", SDL_arraysize( linux_binaryPath ) );
-- strncpy( linux_dataPath, "/share/games/egoboo-2.x/", SDL_arraysize( linux_dataPath ) );
-+ strncpy( linux_dataPath, "@GENTOO_DATADIR@", SDL_arraysize( linux_dataPath ) );
- #endif
-
- // the log file cannot be started until there is a user data path to dump the file into
---- a/src/game/network.c 2012-04-29 20:14:31.482179973 +0200
-+++ b/src/game/network.c 2012-04-29 20:14:52.077730184 +0200
-@@ -37,7 +37,7 @@
- #include "egoboo_setup.h"
- #include "egoboo.h"
-
--#include "enet/enet.h"
-+#include <enet/enet.h>
- #include "file_common.h"
-
- #include <stdarg.h>
---- a/src/game/Makefile 2012-04-29 20:17:09.303070070 +0200
-+++ b/src/game/Makefile 2012-04-29 20:18:21.047023847 +0200
-@@ -33,8 +33,7 @@
- # the compiler options
-
--CC := gcc
--INC := -I. -I.. -I../enet/include ${SDLCONF_I} -I./extensions -I./file_formats -I./platform
--LDFLAGS := ${SDLCONF_L} -L../enet/lib -lSDL_ttf -lSDL_mixer -lGL -lGLU -lSDL_image -lphysfs -lenet
-+INC := -I. -I.. ${SDLCONF_I} -I./extensions -I./file_formats -I./platform
-+LDLIBS := ${SDLCONF_L} -lSDL_ttf -lSDL_mixer -lGL -lGLU -lSDL_image -lphysfs -lenet -lm
-
- # use different options if the environmental variable PREFIX is defined
- ifdef ($(PREFIX),"")
-@@ -43,7 +43,7 @@
- OPT := -Os -Wall -DPREFIX=\"${PREFIX}\" -D_NIX_PREFIX
- endif
-
--CFLAGS := ${OPT} ${INC}
-+CFLAGS += ${INC} -DENET11
-
- #------------------------------------
- # definitions of the target projects
-@@ -52,7 +52,7 @@
- all: ${EGO_BIN}
-
- ${EGO_BIN}: ${EGO_OBJ}
-- ${CC} -o $@ $^ ${LDFLAGS} ${CFLAGS}
-+ ${CC} -o $@ $^ ${LDFLAGS} ${CFLAGS} ${LDLIBS}
-
- clean:
- rm -f ${ENET_OBJ} ${EGO_OBJ} ${EGO_BIN}
+--- a/src/game/Makefile
++++ b/src/game/Makefile
+@@ -34,5 +34,4 @@
+
+-CC := gcc
+-INC := -I. -I.. -I../enet/include ${SDLCONF_I} -I./extensions -I./file_formats -I./platform
+-LDFLAGS := ${SDLCONF_L} -L../enet/lib -lSDL_ttf -lSDL_mixer -lGL -lGLU -lSDL_image -lphysfs -lenet
++INC := -I. -I.. ${SDLCONF_I} -I./extensions -I./file_formats -I./platform
++LDLIBS := ${SDLCONF_L} -lSDL_ttf -lSDL_mixer -lGL -lGLU -lSDL_image -lphysfs -lenet -lm
+
+@@ -45,3 +44,3 @@
+
+-CFLAGS := ${OPT} ${INC}
++CFLAGS += ${INC} -DENET11
+
+@@ -55,3 +54,3 @@
+ ${EGO_BIN}: ${EGO_OBJ}
+- ${CC} -o $@ $^ ${LDFLAGS} ${CFLAGS}
++ ${CC} -o $@ $^ ${LDFLAGS} ${CFLAGS} ${LDLIBS}
+
+--- a/src/game/network.c
++++ b/src/game/network.c
+@@ -39,3 +39,3 @@
+
+-#include "enet/enet.h"
++#include <enet/enet.h>
+ #include "file_common.h"
+--- a/src/game/platform/file_linux.c
++++ b/src/game/platform/file_linux.c
+@@ -81,5 +81,5 @@
+ // these are read-only directories
+- strncpy( linux_configPath, "/etc/egoboo-2.x/", SDL_arraysize( linux_configPath ) );
++ strncpy( linux_configPath, "@GENTOO_CONFDIR@", SDL_arraysize( linux_configPath ) );
+ strncpy( linux_binaryPath, "/games/", SDL_arraysize( linux_binaryPath ) );
+- strncpy( linux_dataPath, "/share/games/egoboo-2.x/", SDL_arraysize( linux_dataPath ) );
++ strncpy( linux_dataPath, "@GENTOO_DATADIR@", SDL_arraysize( linux_dataPath ) );
+ #endif