summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-01-24 18:28:25 -0500
committerIonen Wolkens <ionen@gentoo.org>2023-01-24 18:28:25 -0500
commitec7834f32b220169f98dac9f48955d261abb1d35 (patch)
tree64fa5eef428d928d914825d3318c5b077691a213 /games-rpg
parentgames-rpg/freedroidrpg: add 1.0 (diff)
downloadgentoo-ec7834f32b220169f98dac9f48955d261abb1d35.tar.gz
gentoo-ec7834f32b220169f98dac9f48955d261abb1d35.tar.bz2
gentoo-ec7834f32b220169f98dac9f48955d261abb1d35.zip
games-rpg/freedroidrpg: drop vulnerable 1.0_rc3
Bug: https://bugs.gentoo.org/729326 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'games-rpg')
-rw-r--r--games-rpg/freedroidrpg/Manifest1
-rw-r--r--games-rpg/freedroidrpg/freedroidrpg-1.0_rc3.ebuild73
2 files changed, 0 insertions, 74 deletions
diff --git a/games-rpg/freedroidrpg/Manifest b/games-rpg/freedroidrpg/Manifest
index 8e4af3f8ef8d..93cf3f364dc5 100644
--- a/games-rpg/freedroidrpg/Manifest
+++ b/games-rpg/freedroidrpg/Manifest
@@ -1,2 +1 @@
DIST freedroidRPG-1.0.tar.gz 237703530 BLAKE2B 78531d4e434faecbe34ba34c9996baff8906679916f645ab45d0003b47f55dda6e3a617a39a66aa74185f0983e35cababea2c2240ad42ba0d7a61e73b2308013 SHA512 e3cac480e9db02b2991da674ec6357b1d660996f3fa3eeb75f0908ca653a637eeb44239c1cd7540087f27195e460100d08aa022f6812db72387647218c7bcb29
-DIST freedroidRPG-1.0rc3.tar.gz 237674000 BLAKE2B 44031686ccd9af3bb082ec9cd2bf233792d2b1019a35b0fc2585df39a05b678ef784f9ff5861fbbcfe7ea624a338f6ab28f855158b7c1d18d52fa9e410410d7d SHA512 51125619fb57f8cb16746b3ff100175ab7917c567c8b1efcbc1aebc80a4774501a934b2fd544d65f1420212f9043015c2b88f08d785e765a30ce478157d887fd
diff --git a/games-rpg/freedroidrpg/freedroidrpg-1.0_rc3.ebuild b/games-rpg/freedroidrpg/freedroidrpg-1.0_rc3.ebuild
deleted file mode 100644
index eac95c617462..000000000000
--- a/games-rpg/freedroidrpg/freedroidrpg-1.0_rc3.ebuild
+++ /dev/null
@@ -1,73 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-LUA_COMPAT=( lua5-3 )
-PYTHON_COMPAT=( python3_{9..11} )
-inherit lua-single python-any-r1 xdg
-
-MY_PV=$(ver_rs 2 '')
-
-DESCRIPTION="Modification of the classical Freedroid engine into an RPG"
-HOMEPAGE="https://www.freedroid.org/"
-SRC_URI="https://ftp.osuosl.org/pub/freedroid/freedroidRPG-$(ver_cut 1-2)/freedroidRPG-${MY_PV}.tar.gz"
-S="${WORKDIR}/${PN}-${MY_PV^^}"
-
-LICENSE="GPL-2+"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~x86"
-IUSE="debug devtools opengl profile +sound"
-REQUIRED_USE="${LUA_REQUIRED_USE}"
-
-RDEPEND="
- ${LUA_DEPS}
- media-libs/libjpeg-turbo
- media-libs/libpng:=
- media-libs/libsdl[opengl?,sound?,video]
- media-libs/sdl-gfx:=
- media-libs/sdl-image[jpeg,png]
- sys-libs/zlib:=
- virtual/libintl
- devtools? ( media-libs/sdl-ttf )
- opengl? (
- media-libs/glew:0=
- virtual/opengl
- )
- sound? (
- media-libs/libogg
- media-libs/libvorbis
- media-libs/sdl-mixer[vorbis]
- )"
-DEPEND="${RDEPEND}"
-BDEPEND="
- ${PYTHON_DEPS}
- sys-devel/gettext
- app-alternatives/awk
- virtual/pkgconfig"
-
-pkg_setup() {
- lua-single_pkg_setup
- python-any-r1_pkg_setup
-}
-
-src_prepare() {
- default
-
- python_fix_shebang src/gen_savestruct.py # build only
- rm data/sound/speak.py || die # unused, skip install / python rdep
-}
-
-src_configure() {
- local econfargs=(
- $(use_enable debug backtrace)
- $(use_enable debug)
- $(use_enable devtools dev-tools)
- $(use_enable opengl)
- $(use_enable profile rtprof)
- $(use_enable sound)
- $(use_with debug extra-warnings)
- )
-
- econf "${econfargs[@]}"
-}