summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-simulation/dangerdeep
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-simulation/dangerdeep')
-rw-r--r--games-simulation/dangerdeep/Manifest2
-rw-r--r--games-simulation/dangerdeep/dangerdeep-0.3.0.ebuild63
-rw-r--r--games-simulation/dangerdeep/files/dangerdeep-0.3.0-build.patch39
-rw-r--r--games-simulation/dangerdeep/files/dangerdeep-0.3.0-gcc43.patch80
-rw-r--r--games-simulation/dangerdeep/files/dangerdeep-0.3.0-gcc44.patch20
-rw-r--r--games-simulation/dangerdeep/files/dangerdeep-0.3.0-gcc47.patch10
-rw-r--r--games-simulation/dangerdeep/metadata.xml8
7 files changed, 222 insertions, 0 deletions
diff --git a/games-simulation/dangerdeep/Manifest b/games-simulation/dangerdeep/Manifest
new file mode 100644
index 000000000000..6f9a3c89db07
--- /dev/null
+++ b/games-simulation/dangerdeep/Manifest
@@ -0,0 +1,2 @@
+DIST dangerdeep-0.3.0.tar.gz 1100972 SHA256 bdab6b9b1c2b5f8e618f5c346965ec1f48c9edc9bff1d4f5ff7c8d235464283f SHA512 97d47654d6d3728365ec0f7955f360a35ad105442663f5dd05f0a37ae6ae67216eb33f183df788c3cd0ba9878dbef22d607ddac86bf43159e87ef1c2429b7f87 WHIRLPOOL bdd7c2b089fe50500a16a2ff882a9b72236e69f5218fe1bfd8d2443edf851aeafd03deb3c8c6269ce1219ae8d2e83300251d8fbda5df93b13169bdcd6480cdb3
+DIST dangerdeep-data-0.3.0.zip 61914764 SHA256 00412a4f8f571a9291df48fa40fbbe846680b4fcb1de2f168539b1606cb4fb81 SHA512 c6d7de055abc77c1c61d0f999d885f44121934d66f89c8e4e55231cc20605ef679cd278bebadc879862e3da07d46bae3ab02f97d3ee4179762efd895e8f91b3e WHIRLPOOL 47eeca4f4c0ff4f573b26938c5db8f0c4f9f8c2f4d77de34fa2362a1cfa396a176553efb3928818d61c96b0c6f915a9157b8cc97918821875bdefff2cf10b3c7
diff --git a/games-simulation/dangerdeep/dangerdeep-0.3.0.ebuild b/games-simulation/dangerdeep/dangerdeep-0.3.0.ebuild
new file mode 100644
index 000000000000..f0d22bf06ff2
--- /dev/null
+++ b/games-simulation/dangerdeep/dangerdeep-0.3.0.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils scons-utils games
+
+DESCRIPTION="a World War II German submarine simulation"
+HOMEPAGE="http://dangerdeep.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz
+ mirror://sourceforge/${PN}/${PN}-data-${PV}.zip"
+
+LICENSE="GPL-2 CC-BY-NC-ND-2.0"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="cpu_flags_x86_sse debug"
+
+RDEPEND="virtual/opengl
+ virtual/glu
+ sci-libs/fftw:3.0
+ media-libs/libsdl[joystick,opengl,video]
+ media-libs/sdl-mixer[vorbis]
+ media-libs/sdl-image[jpeg,png]
+ media-libs/sdl-net"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-build.patch \
+ "${FILESDIR}"/${P}-gcc43.patch \
+ "${FILESDIR}"/${P}-gcc47.patch \
+ "${FILESDIR}"/${P}-gcc44.patch
+ sed -i -e "/console_log.txt/ s:fopen.*:stderr;:" src/system.cpp || die
+}
+
+src_compile() {
+ local sse=-1
+
+ if use cpu_flags_x86_sse ; then
+ use amd64 && sse=3 || sse=1
+ fi
+
+ escons \
+ usex86sse=${sse} \
+ datadir="${GAMES_DATADIR}"/${PN} \
+ $(use_scons debug)
+}
+
+src_install() {
+ dogamesbin build/linux/${PN}
+
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r ../data/*
+
+ newicon dftd_icon.png ${PN}.png
+ make_desktop_entry ${PN} "Danger from the Deep"
+
+ dodoc ChangeLog CREDITS README
+ doman doc/man/${PN}.6
+
+ prepgamesdirs
+}
diff --git a/games-simulation/dangerdeep/files/dangerdeep-0.3.0-build.patch b/games-simulation/dangerdeep/files/dangerdeep-0.3.0-build.patch
new file mode 100644
index 000000000000..367db1cfbb96
--- /dev/null
+++ b/games-simulation/dangerdeep/files/dangerdeep-0.3.0-build.patch
@@ -0,0 +1,39 @@
+--- SConstruct
++++ SConstruct
+@@ -119,6 +119,7 @@
+
+ else:
+ print "Compiling for Unix/Posix/Linux Environment"
++ SConsignFile()
+ env = Environment(ENV = os.environ)
+ env.Append(CPPPATH = ['/usr/include/SDL', '/usr/include/GL'])
+ libpath = ['/usr/X11R6/lib']
+@@ -126,13 +127,18 @@
+ sdllibs = ['SDL', 'SDL_image']
+ ccflags = '-Wall `sdl-config --cflags` `pkg-config --cflags x11`'
+ env.Append(LINKFLAGS = '`pkg-config --libs-only-L x11`')
++ if os.environ.has_key('CXX'):
++ env['CXX'] = os.environ['CXX']
++ if os.environ.has_key('CXXFLAGS'):
++ ccflags += os.environ['CXXFLAGS']
++ if os.environ.has_key('LDFLAGS'):
++ env.Append(LINKFLAGS = os.environ['LDFLAGS'])
+ if (debug >= 3):
+ ccflags += ' -g -pg -O3' # profiling
+ elif (debug == 2):
+ ccflags += ' -g -O0'
+ env.Append(CPPDEFINES = ['DEBUG'])
+ elif (debug == 1):
+- ccflags += ' -g -O1'
+ env.Append(CPPDEFINES = ['DEBUG'])
+ elif (debug == -1):
+ ccflags += ' -g -O3 -march=athlon-xp -mfpmath=sse -mmmx -msse -m3dnow'
+@@ -140,8 +144,6 @@
+ ccflags += ' -g -O3 -march=athlon-xp -mfpmath=sse -mmmx -msse -m3dnow -ftree-vectorize -ftree-vectorizer-verbose=2'
+ elif (debug == -3): # special g++4.0+ auto vectorization
+ ccflags += ' -g -O3 -march=athlon64 -mfpmath=sse -mmmx -msse -msse2 -m3dnow -ftree-vectorize -ftree-vectorizer-verbose=2'
+- else:
+- ccflags += ' -g -O2' # debug symbols will be stripped by the linker for a debian package
+ # choose specific architecture if requested
+ if archflag != '':
+ ccflags += ' -march=' + archflag
diff --git a/games-simulation/dangerdeep/files/dangerdeep-0.3.0-gcc43.patch b/games-simulation/dangerdeep/files/dangerdeep-0.3.0-gcc43.patch
new file mode 100644
index 000000000000..1588b0bbae07
--- /dev/null
+++ b/games-simulation/dangerdeep/files/dangerdeep-0.3.0-gcc43.patch
@@ -0,0 +1,80 @@
+--- src/bspline_test.cpp
++++ src/bspline_test.cpp
+@@ -1,6 +1,7 @@
+ // some test code for the 2d bsplines!
+ #include "bspline.h"
+ #include <fstream>
++#include <cstdlib>
+ using namespace std;
+
+ double rnd() { return double(rand())/RAND_MAX; }
+--- src/convoy.h
++++ src/convoy.h
+@@ -27,6 +27,7 @@
+ #include "vector2.h"
+ #include <new>
+ #include <list>
++#include <memory>
+ class ship;
+
+ ///\brief Grouping of ships and other objects with central control.
+--- src/date.cpp
++++ src/date.cpp
+@@ -21,6 +21,7 @@
+ // subsim (C)+(W) Markus Petermann and Thorsten Jordan. SEE LICENSE
+
+ #include <iomanip>
++#include <cstdlib>
+ #include "date.h"
+ #include "texts.h"
+
+--- src/ocean_wave_generator.h
++++ src/ocean_wave_generator.h
+@@ -29,6 +29,7 @@
+ #include "environment.h"
+ #include <complex>
+ #include <vector>
++#include <cstdlib>
+
+ // use float fftw (faster) or double (default) ?
+ #ifdef WITH_FLOAT_FFTW
+--- src/ptrlist.h
++++ src/ptrlist.h
+@@ -25,6 +25,7 @@
+
+ #include <list>
+ #include <stdexcept>
++#include <memory>
+
+ // same as std::list regarding the interface (partly), but handles pointers.
+ template <class T>
+--- src/ptrvector.h
++++ src/ptrvector.h
+@@ -25,6 +25,7 @@
+
+ #include <vector>
+ #include <stdexcept>
++#include <memory>
+
+ // same as std::vector regarding the interface, but handles pointers.
+ template <class T>
+--- src/sea_object.h
++++ src/sea_object.h
+@@ -27,6 +27,7 @@
+ #include "ptrvector.h"
+ #include <new>
+ #include <stdexcept>
++#include <memory>
+
+ #include "vector3.h"
+ #include "angle.h"
+--- src/widget.cpp
++++ src/widget.cpp
+@@ -32,6 +32,7 @@
+ #include "datadirs.h"
+ #include <set>
+ #include <sstream>
++#include <algorithm>
+ using std::vector;
+ using std::list;
+ using std::string;
diff --git a/games-simulation/dangerdeep/files/dangerdeep-0.3.0-gcc44.patch b/games-simulation/dangerdeep/files/dangerdeep-0.3.0-gcc44.patch
new file mode 100644
index 000000000000..23d3c470c900
--- /dev/null
+++ b/games-simulation/dangerdeep/files/dangerdeep-0.3.0-gcc44.patch
@@ -0,0 +1,20 @@
+--- src/date.cpp
++++ src/date.cpp
+@@ -22,6 +22,7 @@
+
+ #include <iomanip>
+ #include <cstdlib>
++#include <cstdio>
+ #include "date.h"
+ #include "texts.h"
+
+--- src/filehelper.cpp
++++ src/filehelper.cpp
+@@ -23,6 +23,7 @@
+ #include "filehelper.h"
+ #include "error.h"
+ #include <vector>
++#include <cstdio>
+ using namespace std;
+
+ #ifdef WIN32
diff --git a/games-simulation/dangerdeep/files/dangerdeep-0.3.0-gcc47.patch b/games-simulation/dangerdeep/files/dangerdeep-0.3.0-gcc47.patch
new file mode 100644
index 000000000000..54adcec10daf
--- /dev/null
+++ b/games-simulation/dangerdeep/files/dangerdeep-0.3.0-gcc47.patch
@@ -0,0 +1,10 @@
+--- src/faulthandler.h.old 2012-07-25 14:37:32.000000000 +0200
++++ src/faulthandler.h 2012-07-25 14:38:16.000000000 +0200
+@@ -50,6 +50,7 @@
+ #include <signal.h>
+ #include <string>
+ #include <sstream>
++#include <unistd.h>
+
+ // Note: use --export-dynamic as linker option or you won't get function names here.
+
diff --git a/games-simulation/dangerdeep/metadata.xml b/games-simulation/dangerdeep/metadata.xml
new file mode 100644
index 000000000000..f6539c9a89b3
--- /dev/null
+++ b/games-simulation/dangerdeep/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <upstream>
+ <remote-id type="sourceforge">dangerdeep</remote-id>
+ </upstream>
+</pkgmetadata>