summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2019-04-03 14:18:16 +0200
committerLars Wendler <polynomial-c@gentoo.org>2019-04-03 14:20:45 +0200
commite6b14dd3d154e5ff05ac29e4d71e55a6ed0b1b60 (patch)
tree355d8551130463b4f9b1cf5e1487dd0fc4dbdb15 /games-simulation/openttd/files
parentapp-office/libreoffice: 6.2.3.1 version bump, pre-release w/o keywords (diff)
downloadgentoo-e6b14dd3d154e5ff05ac29e4d71e55a6ed0b1b60.tar.gz
gentoo-e6b14dd3d154e5ff05ac29e4d71e55a6ed0b1b60.tar.bz2
gentoo-e6b14dd3d154e5ff05ac29e4d71e55a6ed0b1b60.zip
games-simulation/openttd: Bump live ebuild to EAPI-7
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'games-simulation/openttd/files')
-rw-r--r--games-simulation/openttd/files/openttd-1.9.0-cflags.patch56
-rw-r--r--games-simulation/openttd/files/openttd-1.9.0-dont_compress_manpages.patch34
2 files changed, 90 insertions, 0 deletions
diff --git a/games-simulation/openttd/files/openttd-1.9.0-cflags.patch b/games-simulation/openttd/files/openttd-1.9.0-cflags.patch
new file mode 100644
index 000000000000..86eb16168dbc
--- /dev/null
+++ b/games-simulation/openttd/files/openttd-1.9.0-cflags.patch
@@ -0,0 +1,56 @@
+From 6d72f33efe9f911d1427795a06c13d9dcd6fa222 Mon Sep 17 00:00:00 2001
+From: Lars Wendler <polynomial-c@gentoo.org>
+Date: Wed, 3 Apr 2019 14:11:42 +0200
+Subject: [PATCH] Don't mess with our CFLAGS
+
+Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
+---
+ config.lib | 18 ------------------
+ 1 file changed, 18 deletions(-)
+
+diff --git a/config.lib b/config.lib
+index f65aaa535..7789c0bea 100644
+--- a/config.lib
++++ b/config.lib
+@@ -1499,11 +1499,6 @@ make_cflags_and_ldflags() {
+ # No debug, add default stuff
+ OBJS_SUBDIR="release"
+
+- if [ "$enable_profiling" = "0" ]; then
+- # -fomit-frame-pointer and -pg do not go well together (gcc errors they are incompatible)
+- CFLAGS="-fomit-frame-pointer $CFLAGS"
+- fi
+- CFLAGS="-O2 $CFLAGS"
+ else
+ OBJS_SUBDIR="debug"
+
+@@ -1511,14 +1506,6 @@ make_cflags_and_ldflags() {
+ if [ $enable_debug -ge 1 ]; then
+ CFLAGS="$CFLAGS -g -D_DEBUG"
+ fi
+- if [ $enable_debug -ge 2 ]; then
+- CFLAGS="$CFLAGS -fno-inline"
+- fi
+- if [ $enable_debug -ge 3 ]; then
+- CFLAGS="$CFLAGS -O0"
+- else
+- CFLAGS="$CFLAGS -O2"
+- fi
+ fi
+
+ if [ $enable_debug -le 2 ]; then
+@@ -1543,11 +1530,6 @@ make_cflags_and_ldflags() {
+ CFLAGS="$CFLAGS -fno-expensive-optimizations"
+ fi
+
+- if [ "$enable_profiling" != "0" ]; then
+- CFLAGS="$CFLAGS -pg"
+- LDFLAGS="$LDFLAGS -pg"
+- fi
+-
+ if [ "$with_threads" = "0" ]; then
+ CFLAGS="$CFLAGS -DNO_THREADS"
+ fi
+--
+2.21.0
+
diff --git a/games-simulation/openttd/files/openttd-1.9.0-dont_compress_manpages.patch b/games-simulation/openttd/files/openttd-1.9.0-dont_compress_manpages.patch
new file mode 100644
index 000000000000..d151dbf36931
--- /dev/null
+++ b/games-simulation/openttd/files/openttd-1.9.0-dont_compress_manpages.patch
@@ -0,0 +1,34 @@
+From da54b0365997181979d5c7131e99957424d4a167 Mon Sep 17 00:00:00 2001
+From: Lars Wendler <polynomial-c@gentoo.org>
+Date: Wed, 3 Apr 2019 13:53:50 +0200
+Subject: [PATCH] Do not compress man-pages by default
+
+Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
+---
+ Makefile.bundle.in | 3 +--
+ 1 file changed, 1 insertion(+), 2 deletions(-)
+
+diff --git a/Makefile.bundle.in b/Makefile.bundle.in
+index eaf7134dd..1c2523181 100644
+--- a/Makefile.bundle.in
++++ b/Makefile.bundle.in
+@@ -77,7 +77,6 @@ endif
+ ifdef MAN_DIR
+ $(Q)mkdir -p "$(BUNDLE_DIR)/man/"
+ $(Q)cp "$(ROOT_DIR)/docs/openttd.6" "$(BUNDLE_DIR)/man/"
+- $(Q)gzip -9 "$(BUNDLE_DIR)/man/openttd.6"
+ endif
+ $(Q)cp "$(ROOT_DIR)/media/openttd.32.xpm" "$(BUNDLE_DIR)/media/"
+ $(Q)cp "$(ROOT_DIR)/media/openttd."*.png "$(BUNDLE_DIR)/media/"
+@@ -219,7 +218,7 @@ endif
+ ifdef MAN_DIR
+ ifndef DO_NOT_INSTALL_MAN
+ $(Q)install -d "$(INSTALL_MAN_DIR)"
+- $(Q)install -m 644 "$(BUNDLE_DIR)/man/openttd.6.gz" "$(INSTALL_MAN_DIR)/${BINARY_NAME}.6.gz"
++ $(Q)install -m 644 "$(BUNDLE_DIR)/man/openttd.6" "$(INSTALL_MAN_DIR)/${BINARY_NAME}.6"
+ endif
+ endif
+ ifdef MENU_DIR
+--
+2.21.0
+