summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-03-05 02:59:25 +0000
committerSam James <sam@gentoo.org>2023-03-05 02:59:38 +0000
commitb355649c4c23392040d456a20f17d1b56a78312b (patch)
tree19df0b28585e01894356b7eb5ed82bfdf12fd550 /games-simulation/senken/senken-0.3.0-r2.ebuild
parentgames-simulation/lincity: fix configure w/ clang 16 (diff)
downloadgentoo-b355649c4c23392040d456a20f17d1b56a78312b.tar.gz
gentoo-b355649c4c23392040d456a20f17d1b56a78312b.tar.bz2
gentoo-b355649c4c23392040d456a20f17d1b56a78312b.zip
games-simulation/senken: fix implicit func decls
Closes: https://bugs.gentoo.org/899022 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-simulation/senken/senken-0.3.0-r2.ebuild')
-rw-r--r--games-simulation/senken/senken-0.3.0-r2.ebuild62
1 files changed, 62 insertions, 0 deletions
diff --git a/games-simulation/senken/senken-0.3.0-r2.ebuild b/games-simulation/senken/senken-0.3.0-r2.ebuild
new file mode 100644
index 000000000000..a9c9fdf39deb
--- /dev/null
+++ b/games-simulation/senken/senken-0.3.0-r2.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="City simulation game"
+HOMEPAGE="https://savannah.nongnu.org/projects/senken/"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls"
+
+RDEPEND="
+ >=media-libs/libsdl-1.2.4
+ media-libs/sdl-image
+ x11-libs/gtk+:2
+ nls? ( virtual/libintl )
+"
+DEPEND="
+ ${RDEPEND}
+ nls? ( sys-devel/gettext )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-as-needed.patch
+ "${FILESDIR}"/${P}-warnings.patch
+ "${FILESDIR}"/${P}-implicit-function-decl.patch
+)
+
+src_prepare() {
+ default
+
+ sed -i \
+ -e "s:/usr/local/share:/usr/share:" \
+ lib/utils.h || die
+
+ # Clang 16, bug #899022
+ sed -i -e "s:configure.in:configure.ac:" Makefile.in || die
+ eautoconf
+}
+
+src_configure() {
+ econf $(use_enable nls)
+}
+
+src_install() {
+ default
+
+ #dodir "${GAMES_DATADIR}"
+ #mv "${D}/${GAMES_PREFIX}/share/senken" "${D}/${GAMES_DATADIR}/" || die
+ #rm -rf "${D}/${GAMES_PREFIX}"/{include,lib,man,share} || die
+
+ insinto /usr/share/senken/img
+ doins img/*.png
+
+ find "${D}/usr/share/" -type f -exec chmod a-x \{\} +
+ find "${D}/usr/share/" -name "Makefile.*" -exec rm -f \{\} +
+}