summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2019-12-26 18:17:54 +0100
committerPacho Ramos <pacho@gentoo.org>2019-12-26 18:19:20 +0100
commite181864d25b19d28a873169bd04f9e2aac00a77e (patch)
treef85e542cb2025de757792e505dc970d5b30b6558 /games-simulation/singularity
parentnet-libs/serf: Python 3.7 and 3.8 compatibility (diff)
downloadgentoo-e181864d25b19d28a873169bd04f9e2aac00a77e.tar.gz
gentoo-e181864d25b19d28a873169bd04f9e2aac00a77e.tar.bz2
gentoo-e181864d25b19d28a873169bd04f9e2aac00a77e.zip
games-simulation/singularity: Version bump supporting python3
Package-Manager: Portage-2.3.82, Repoman-2.3.20 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'games-simulation/singularity')
-rw-r--r--games-simulation/singularity/Manifest2
-rw-r--r--games-simulation/singularity/singularity-1.0_alpha1.ebuild44
2 files changed, 46 insertions, 0 deletions
diff --git a/games-simulation/singularity/Manifest b/games-simulation/singularity/Manifest
index b82042060603..b77ad70dbed0 100644
--- a/games-simulation/singularity/Manifest
+++ b/games-simulation/singularity/Manifest
@@ -1,2 +1,4 @@
DIST endgame-singularity-music-006.zip 28250705 BLAKE2B 62f39536afe12d0928056cca05cccbc7542d79ce5a2acfb23dc99e66ea291eeadc2ae8e771cfed5a96ff69bdc217b69f44b8c5143a323fa5c06fe2d34ac6d425 SHA512 47e489112309cc742c2dcffec004aff25c54488fdf2a5f2dc67b7dcf67ca55996fe8e8403e4a16712fbc4e22289f12e612ad9d4322cd1d1aaab871f0ffb27e19
+DIST endgame-singularity-music-007.zip 51774799 BLAKE2B 78595b16e422d2312be860686aca9401f6f1eed35fe40dbbc3a3999b1feb5e32aa6d51a66d94c9241aca2b6606bb7135491298b94c8033a1437c2cd7b23f9120 SHA512 ab46e77c833085f0c5b1b46fef72ab807e79ca422ad043ef67a4bf4384cb0177319f21b4bd01496e6c3fc6fe9a2f36ec256e19f0e829ad7bf9f0c5bd38bf0fe5
DIST singularity-0.30c-src.tar.gz 2265133 BLAKE2B a3f7612ac173ef34183ea500d8bef8b1c823b54d0b0acb6a40bce058497d424f76df5fd51da8f1acfb636a556759cea2114529e0e60b453652d0b04a139b19a1 SHA512 ffca50c179b745561a25e3fb3525abb862d72f63f533f8a41472067d0ce94c8a236486c9c40a5040335d84e903c498805d591dc546a92d0a7651105103fe114f
+DIST singularity-1.0a1.tar.gz 1927083 BLAKE2B aeed099dd33c135f5b2e21f5e907646f32aaa0879a1b2e1f09c19045499ae52b004a8f52fee72bfe0977805899e4c7cdff6abf36e9fd3604f73cba7e395c265e SHA512 8ce624a50819e0abc04fd81a1d7658eab64ea8325de0a5790ec2a92e5fa6b62cfef8fe705fe8b209194c05927e3cf5adfc6f48934e0a70edf8b251c24084fc25
diff --git a/games-simulation/singularity/singularity-1.0_alpha1.ebuild b/games-simulation/singularity/singularity-1.0_alpha1.ebuild
new file mode 100644
index 000000000000..5d2e8e29eb0d
--- /dev/null
+++ b/games-simulation/singularity/singularity-1.0_alpha1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7} )
+
+inherit desktop eutils python-single-r1
+
+MUSIC="endgame-${PN}-music-007"
+DESCRIPTION="Simulation of a true AI. Go from computer to computer, chased by the whole world"
+HOMEPAGE="http://www.emhsoft.com/singularity/ https://github.com/singularity/singularity"
+SRC_URI="https://github.com/singularity/singularity/releases/download/${P/_alpha/a}/${P/_alpha/a}.tar.gz
+ http://emhsoft.com/singularity/${MUSIC}.zip"
+
+LICENSE="GPL-2 CC-BY-SA-2.5"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pygame[${PYTHON_USEDEP}]
+ dev-python/polib[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="app-arch/unzip"
+
+S="${WORKDIR}/${P/_alpha/a}"
+
+src_install() {
+ insinto /usr/share/${PN}
+ doins -r "${PN}" "${PN}.py"
+
+ python_optimize "${ED}/usr/share/${PN}"
+
+ insinto /usr/share/${PN}/${PN}/music
+ doins "${WORKDIR}"/${MUSIC}/*
+
+ make_wrapper ${PN} "${EPYTHON} ${PN}.py" /usr/share/${PN}
+ dodoc README.txt TODO Changelog AUTHORS
+
+ domenu "${PN}.desktop"
+ newicon "${PN}"/data/themes/default/images/icon.png "${PN}.png"
+}