summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-03-05 02:32:19 +0000
committerSam James <sam@gentoo.org>2023-03-05 02:59:37 +0000
commit80d25f0b73c2a1a6615400d295933eaf86166893 (patch)
tree6a100bd0879cc6f779565835cb5b5579891bfbde /games-simulation
parentgames-puzzle/xwelltris: fix configure w/ clang 16, C++17, autoconf-2.72 (diff)
downloadgentoo-80d25f0b73c2a1a6615400d295933eaf86166893.tar.gz
gentoo-80d25f0b73c2a1a6615400d295933eaf86166893.tar.bz2
gentoo-80d25f0b73c2a1a6615400d295933eaf86166893.zip
games-simulation/lincity: fix configure w/ clang 16
Closes: https://bugs.gentoo.org/899020 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-simulation')
-rw-r--r--games-simulation/lincity/lincity-1.13.1-r4.ebuild (renamed from games-simulation/lincity/lincity-1.13.1-r3.ebuild)11
1 files changed, 9 insertions, 2 deletions
diff --git a/games-simulation/lincity/lincity-1.13.1-r3.ebuild b/games-simulation/lincity/lincity-1.13.1-r4.ebuild
index c80cf4adcb21..29d3d9a64773 100644
--- a/games-simulation/lincity/lincity-1.13.1-r3.ebuild
+++ b/games-simulation/lincity/lincity-1.13.1-r4.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit desktop
+inherit autotools desktop
DESCRIPTION="City simulation game for X"
HOMEPAGE="http://lincity.sourceforge.net/"
@@ -30,6 +30,13 @@ PATCHES=(
"${FILESDIR}"/${P}-Fix-prototypes-and-implicit-function-declarations.patch
)
+src_prepare() {
+ default
+
+ # Clang 16, bug #899020
+ eautoreconf
+}
+
src_configure() {
local econfargs=(
--with-gzip