summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2016-09-15 11:20:16 -0500
committerAustin English <wizardedit@gentoo.org>2016-09-15 12:18:15 -0500
commit9a223f221cc9bd717eea30e1947e73775ee5763d (patch)
tree96a61f70105649b9b401e4b68ea08dbeff2cdf2a /games-simulation
parentgames-simulation/bcs-demo: remove deprecated games eclass (diff)
downloadgentoo-9a223f221cc9bd717eea30e1947e73775ee5763d.tar.gz
gentoo-9a223f221cc9bd717eea30e1947e73775ee5763d.tar.bz2
gentoo-9a223f221cc9bd717eea30e1947e73775ee5763d.zip
games-simulation/singularity: remove deprecated games eclass
Also update to EAPI 6 Gentoo-Bug: https://bugs.gentoo.org/574082 Package-Manager: portage-2.3.0
Diffstat (limited to 'games-simulation')
-rw-r--r--games-simulation/singularity/singularity-0.30c-r2.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/games-simulation/singularity/singularity-0.30c-r2.ebuild b/games-simulation/singularity/singularity-0.30c-r2.ebuild
new file mode 100644
index 000000000000..e178c5929149
--- /dev/null
+++ b/games-simulation/singularity/singularity-0.30c-r2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+inherit eutils python-single-r1
+
+MUSIC=endgame-${PN}-music-006
+DESCRIPTION="A simulation of a true AI. Go from computer to computer, pursued by the entire world"
+HOMEPAGE="http://www.emhsoft.com/singularity/"
+SRC_URI="https://endgame-singularity.googlecode.com/files/${P}-src.tar.gz
+ music? ( https://endgame-singularity.googlecode.com/files/${MUSIC}.zip )"
+
+LICENSE="GPL-2 CC-BY-SA-2.5"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+music"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}"
+RDEPEND="${DEPEND}
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pygame[${PYTHON_USEDEP}]
+ media-libs/sdl-mixer[vorbis]"
+DEPEND="${DEPEND}
+ app-arch/unzip"
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+
+ rm -f code/{,*}/*.pyc data/*.html || die # Remove unecessary files
+}
+
+src_install() {
+ insinto /usr/share/${PN}
+ doins -r code data ${PN}.py || die
+ python_optimize ${ED%/}/usr/share/${PN}
+
+ if use music ; then
+ doins -r ../${MUSIC}/music || die
+ fi
+
+ make_wrapper ${PN} "${EPYTHON} ${PN}.py" /usr/share/${PN}
+ dodoc README.txt TODO Changelog AUTHORS
+}