summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2021-07-19 11:57:57 -0400
committerIonen Wolkens <ionen@gentoo.org>2021-07-19 12:01:31 -0400
commitbe34bcfc61abb8bdff5b98bd59a700e6200dfdc5 (patch)
treea4f17e6fd1fb5ae61f8fdd52777a148102522436 /games-simulation
parentgames-simulation/crrcsim: EAPI 6->8, cgal[-shared], missing deps (diff)
downloadgentoo-be34bcfc61abb8bdff5b98bd59a700e6200dfdc5.tar.gz
gentoo-be34bcfc61abb8bdff5b98bd59a700e6200dfdc5.tar.bz2
gentoo-be34bcfc61abb8bdff5b98bd59a700e6200dfdc5.zip
games-simulation/crrcsim: drop 0.9.13-r1
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'games-simulation')
-rw-r--r--games-simulation/crrcsim/crrcsim-0.9.13-r1.ebuild58
-rw-r--r--games-simulation/crrcsim/files/crrcsim-0.9.13-buildsystem.patch62
-rw-r--r--games-simulation/crrcsim/files/crrcsim-cgal_gmp.patch11
3 files changed, 0 insertions, 131 deletions
diff --git a/games-simulation/crrcsim/crrcsim-0.9.13-r1.ebuild b/games-simulation/crrcsim/crrcsim-0.9.13-r1.ebuild
deleted file mode 100644
index cf65eba9ef26..000000000000
--- a/games-simulation/crrcsim/crrcsim-0.9.13-r1.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit autotools eutils gnome2-utils
-
-DESCRIPTION="model-airplane flight simulation program"
-HOMEPAGE="https://sourceforge.net/projects/crrcsim/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="portaudio"
-
-RDEPEND="media-libs/libsdl[X,sound,joystick,opengl,video]
- media-libs/plib
- sci-mathematics/cgal[shared(+)]
- portaudio? ( media-libs/portaudio )"
-DEPEND="${RDEPEND}"
-
-PATCHES=(
- "${FILESDIR}"/${P}-buildsystem.patch
- "${FILESDIR}"/${P}-gcc6.patch
-)
-
-src_prepare() {
- default
-
- if has_version "sci-mathematics/cgal[gmp(+)]" ; then
- eapply "${FILESDIR}"/${PN}-cgal_gmp.patch
- fi
- eautoreconf
-}
-
-src_configure() {
- econf $(use_with portaudio)
-}
-
-src_install() {
- emake DESTDIR="${D}" install
- dodoc AUTHORS HISTORY NEWS README
- doicon -s 32 packages/icons/${PN}.png
- make_desktop_entry ${PN}
-}
-
-pkg_preinst() {
- gnome2_icon_savelist
-}
-
-pkg_postinst() {
- gnome2_icon_cache_update
-}
-
-pkg_postrm() {
- gnome2_icon_cache_update
-}
diff --git a/games-simulation/crrcsim/files/crrcsim-0.9.13-buildsystem.patch b/games-simulation/crrcsim/files/crrcsim-0.9.13-buildsystem.patch
deleted file mode 100644
index 396fd573ec90..000000000000
--- a/games-simulation/crrcsim/files/crrcsim-0.9.13-buildsystem.patch
+++ /dev/null
@@ -1,62 +0,0 @@
---- crrcsim-0.9.11/configure.ac
-+++ crrcsim-0.9.11/configure.ac
-@@ -79,8 +79,12 @@
- dnl Default is: no portaudio present
- portaudio=0
-
-+AC_ARG_WITH([portaudio], AS_HELP_STRING([--without-portaudio], [Build without portaudio library (default: test)]))
-+
-+AS_IF([test "x$with_portaudio" != "xno"], [
- dnl Check for the Portaudio header file
- AC_CHECK_HEADER([portaudio.h])
-+])
-
- if (test "x$ac_cv_header_portaudio_h" = "xyes"); then
- dnl Check for Portaudio 18
---- crrcsim-0.9.13/src/mod_misc/filesystools.cpp
-+++ crrcsim-0.9.13/src/mod_misc/filesystools.cpp
-@@ -113,8 +113,8 @@
- // $USERPROFILE/.crrcsim (WIN32)
- // $HOME/.crrcsim (LINUX)
- // CRRC_DATA_PATH (LINUX)
-- // /usr/local/share/games/crrcsim (LINUX)
-- // /usr/share/games/crrcsim (LINUX)
-+ // /usr/local/share/crrcsim (LINUX)
-+ // /usr/share/crrcsim (LINUX)
-
- // cwd
- if (dirname != "")
-@@ -154,13 +154,13 @@
- s.append(dirname);
- pathlist.push_back(s);
- #endif
-- s = "/usr/local/share/games/" + appname + "/";
-+ s = "/usr/local/share/" + appname + "/";
- if (s != data_path) // avoid adding this path twice
- {
- s.append(dirname);
- pathlist.push_back(s);
- }
-- s = "/usr/share/games/" + appname + "/";
-+ s = "/usr/share/" + appname + "/";
- if (s != data_path) // avoid adding this path twice
- {
- s.append(dirname);
-@@ -172,13 +172,13 @@
- #ifdef CRRC_DATA_PATH
- pathlist.push_back(data_path);
- #endif
-- if (data_path != "/usr/local/share/games/" + appname) // avoid adding this path twice
-+ if (data_path != "/usr/local/share/" + appname) // avoid adding this path twice
- {
-- pathlist.push_back("/usr/local/share/games/" + appname);
-+ pathlist.push_back("/usr/local/share/" + appname);
- }
-- if (data_path != "/usr/share/games/" + appname) // avoid adding this path twice
-+ if (data_path != "/usr/share/" + appname) // avoid adding this path twice
- {
-- pathlist.push_back("/usr/share/games/" + appname);
-+ pathlist.push_back("/usr/share/" + appname);
- }
- }
- #endif
diff --git a/games-simulation/crrcsim/files/crrcsim-cgal_gmp.patch b/games-simulation/crrcsim/files/crrcsim-cgal_gmp.patch
deleted file mode 100644
index 10d6bff6b769..000000000000
--- a/games-simulation/crrcsim/files/crrcsim-cgal_gmp.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- crrcsim-0.9.11/configure.ac
-+++ crrcsim-0.9.11/configure.ac
-@@ -229,7 +229,7 @@
- has_CGAL="yes (found CGAL v3)"
- fi
- CGAL_CFLAGS=-frounding-math
-- CGAL_LIBS=-lCGAL
-+ CGAL_LIBS="-lCGAL -lgmp"
- AC_DEFINE([WINDDATA3D], [1], [Import code for wind data, needs CGAL, 0 to disable])
- else
- has_CGAL="no (CGAL not found)"