summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2020-11-11 10:19:21 +0100
committerLars Wendler <polynomial-c@gentoo.org>2020-11-11 12:22:14 +0100
commitd44391b8ac3c5cf88c2b3b20b0a580e9ebbd3ae1 (patch)
tree3d86a86eb74e0b4640c5954b6eefd82e6b36fdfd /games-simulation
parentsci-chemistry/gromacs: Remove old 2020.x releases (diff)
downloadgentoo-d44391b8ac3c5cf88c2b3b20b0a580e9ebbd3ae1.tar.gz
gentoo-d44391b8ac3c5cf88c2b3b20b0a580e9ebbd3ae1.tar.bz2
gentoo-d44391b8ac3c5cf88c2b3b20b0a580e9ebbd3ae1.zip
games-simulation/openttd: Fixed build with >=dev-libs/icu-68.1
Closes: https://bugs.gentoo.org/751949 Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'games-simulation')
-rw-r--r--games-simulation/openttd/files/openttd-1.10.3-icu68.patch28
-rw-r--r--games-simulation/openttd/openttd-1.10.3.ebuild1
2 files changed, 29 insertions, 0 deletions
diff --git a/games-simulation/openttd/files/openttd-1.10.3-icu68.patch b/games-simulation/openttd/files/openttd-1.10.3-icu68.patch
new file mode 100644
index 000000000000..9596ab66606a
--- /dev/null
+++ b/games-simulation/openttd/files/openttd-1.10.3-icu68.patch
@@ -0,0 +1,28 @@
+From 842e0ed5e3220a0e5ab19e7b0892c9c72c230ae7 Mon Sep 17 00:00:00 2001
+From: Lars Wendler <polynomial-c@gentoo.org>
+Date: Fri, 30 Oct 2020 18:45:20 +0100
+Subject: [PATCH] Fix: build with icu-68.1
+
+icu-68.1 removed public macro definitions for TRUE and FALSE
+
+Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
+---
+ src/gfx_layout.cpp | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/gfx_layout.cpp b/src/gfx_layout.cpp
+index 584a71273..ebd1afaa8 100644
+--- a/src/gfx_layout.cpp
++++ b/src/gfx_layout.cpp
+@@ -116,7 +116,7 @@ void Font::getGlyphAdvance(LEGlyphID glyph, LEPoint &advance) const
+
+ le_bool Font::getGlyphPoint(LEGlyphID glyph, le_int32 pointNumber, LEPoint &point) const
+ {
+- return FALSE;
++ return false;
+ }
+
+ /**
+--
+2.29.2
+
diff --git a/games-simulation/openttd/openttd-1.10.3.ebuild b/games-simulation/openttd/openttd-1.10.3.ebuild
index acf83d2f9551..8bad288e5649 100644
--- a/games-simulation/openttd/openttd-1.10.3.ebuild
+++ b/games-simulation/openttd/openttd-1.10.3.ebuild
@@ -62,6 +62,7 @@ PDEPEND="
PATCHES=(
"${FILESDIR}"/${PN}-1.9.0-cflags.patch
"${FILESDIR}"/${PN}-1.9.0-dont_compress_manpages.patch
+ "${FILESDIR}"/${P}-icu68.patch
)
src_configure() {