summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-02-27 21:42:23 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2021-02-28 13:26:12 +0100
commit264ed33695564ee00900e8c6f8ec9fc065e72fe3 (patch)
tree7bb7488a6af6606550e8834d1ff486465d881b63 /games-strategy/freesynd/files
parentgames-strategy/maxr: EAPI-7 bump, switch to cmake.eclass (diff)
downloadgentoo-264ed33695564ee00900e8c6f8ec9fc065e72fe3.tar.gz
gentoo-264ed33695564ee00900e8c6f8ec9fc065e72fe3.tar.bz2
gentoo-264ed33695564ee00900e8c6f8ec9fc065e72fe3.zip
games-strategy/freesynd: 0.7.5 version bump, cmake.eclass
Package-Manager: Portage-3.0.16, Repoman-3.0.2 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'games-strategy/freesynd/files')
-rw-r--r--games-strategy/freesynd/files/freesynd-0.7.5-cmake.patch28
1 files changed, 28 insertions, 0 deletions
diff --git a/games-strategy/freesynd/files/freesynd-0.7.5-cmake.patch b/games-strategy/freesynd/files/freesynd-0.7.5-cmake.patch
new file mode 100644
index 000000000000..6448271b1f99
--- /dev/null
+++ b/games-strategy/freesynd/files/freesynd-0.7.5-cmake.patch
@@ -0,0 +1,28 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -34,6 +34,13 @@
+ set (CMAKE_C_FLAGS "${CMAKE_C_FLAGS} ${EXTRA_C_FLAGS}")
+ set (CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${EXTRA_CXX_FLAGS}")
+
++option(BUILD_DEV_TOOLS "Build development tools")
++option(WITH_DEBUG "Enable debug definitions")
++
++if(WITH_DEBUG)
++ add_definitions (-D_DEBUG)
++endif()
++
+ # Set standard definitions for all platforms.
+ add_definitions (-DSYSTEM_SDL)
+ add_definitions (-DPREFIX=\"${CMAKE_INSTALL_PREFIX}\")
+@@ -59,10 +66,7 @@
+ message (FATAL_ERROR "Unable to locate PNG")
+ endif ()
+
+-if (CMAKE_BUILD_TYPE STREQUAL "debug" OR CMAKE_BUILD_TYPE STREQUAL "Debug")
+- set (BUILD_DEV_TOOLS TRUE)
+-else ()
+- set (BUILD_DEV_TOOLS FALSE)
++if (CMAKE_BUILD_TYPE AND NOT CMAKE_BUILD_TYPE STREQUAL "debug")
+ # We only define an install target if we're doing a release build.
+ # Furthermore, on Mac, the data folder is a part of the app bundle.
+ if (NOT APPLE)