summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-strategy/ja2-stracciatella/ja2-stracciatella-0.12.1_p7072.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-strategy/ja2-stracciatella/ja2-stracciatella-0.12.1_p7072.ebuild')
-rw-r--r--games-strategy/ja2-stracciatella/ja2-stracciatella-0.12.1_p7072.ebuild88
1 files changed, 88 insertions, 0 deletions
diff --git a/games-strategy/ja2-stracciatella/ja2-stracciatella-0.12.1_p7072.ebuild b/games-strategy/ja2-stracciatella/ja2-stracciatella-0.12.1_p7072.ebuild
new file mode 100644
index 000000000000..936f5b335241
--- /dev/null
+++ b/games-strategy/ja2-stracciatella/ja2-stracciatella-0.12.1_p7072.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils games
+
+DESCRIPTION="A port of Jagged Alliance 2 to SDL"
+HOMEPAGE="http://tron.homeunix.org/ja2/"
+SRC_URI="http://dev.gentoo.org/~hasufell/distfiles/${P}.tar.xz
+ http://tron.homeunix.org/ja2/editor.slf.gz"
+
+LICENSE="SFI-SCLA"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="cdinstall editor zlib"
+
+RDEPEND="media-libs/libsdl[X,sound,video]
+ cdinstall? ( games-strategy/ja2-stracciatella-data )
+ zlib? ( sys-libs/zlib )"
+
+LANGS="linguas_de +linguas_en linguas_fr linguas_it linguas_nl linguas_pl linguas_ru linguas_ru_gold"
+IUSE="$IUSE $LANGS"
+REQUIRED_USE="^^ ( ${LANGS//+/} )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-makefile.patch
+
+ sed \
+ -e "s:/some/place/where/the/data/is:${GAMES_DATADIR}/ja2:" \
+ -i sgp/FileMan.cc || die
+
+ sed \
+ -e "s:@GAMES_DATADIR@:${GAMES_DATADIR}/ja2/data:" \
+ "${FILESDIR}"/ja2-convert.sh > "${T}"/ja2-convert || die
+}
+
+src_compile() {
+ local myconf
+
+ case ${LINGUAS} in
+ de) myconf="LNG=GERMAN" ;;
+ nl) myconf="LNG=DUTCH" ;;
+ fr) myconf="LNG=FRENCH" ;;
+ it) myconf="LNG=ITALIAN" ;;
+ pl) myconf="LNG=POLISH" ;;
+ ru) myconf="LNG=RUSSIAN" ;;
+ ru_gold) myconf="LNG=RUSSIAN_GOLD" ;;
+ en) myconf="LNG=ENGLISH" ;;
+ *) die "wat" ;;
+ esac
+ elog "Chosen language is ${myconf#LNG=}"
+
+ use editor && myconf+=" JA2EDITOR=yes JA2BETAVERSION=yes"
+ use zlib && myconf+=" WITH_ZLIB=yes"
+
+ emake ${myconf}
+}
+
+src_install() {
+ dogamesbin ja2 "${T}"/ja2-convert
+
+ if use editor; then
+ insinto "${GAMES_DATADIR}"/ja2/data
+ doins "${WORKDIR}"/editor.slf
+ fi
+
+ make_desktop_entry ja2 ${PN}
+ doman ja2.6
+
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+
+ elog "You need ja2 in the chosen language, otherwise set it in package.use!"
+
+ if ! use cdinstall ; then
+ elog "You need to copy all files from the Data directory of"
+ elog "Jagged Alliance 2 installation to"
+ elog "${GAMES_DATADIR}/ja2/data "
+ elog "Make sure the filenames are lowercase. You may want to run the"
+ elog "script":
+ elog "${GAMES_BINDIR}/ja2-convert"
+ fi
+}