summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2020-12-09 22:44:06 +0000
committerJames Le Cuirot <chewi@gentoo.org>2020-12-09 22:44:06 +0000
commit7eb00f29fd1edfa3df8af8f6ea813721c03ef9e4 (patch)
tree873dffa17de17d93838591b5088e9f5d7ea4a810 /games-strategy/julius
parentgames-strategy/julius: new package (diff)
downloadgentoo-7eb00f29fd1edfa3df8af8f6ea813721c03ef9e4.tar.gz
gentoo-7eb00f29fd1edfa3df8af8f6ea813721c03ef9e4.tar.bz2
gentoo-7eb00f29fd1edfa3df8af8f6ea813721c03ef9e4.zip
games-strategy/julius: Add xdg eclass to handle icon cache
Package-Manager: Portage-3.0.12, Repoman-3.0.1 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'games-strategy/julius')
-rw-r--r--games-strategy/julius/julius-1.4.1.ebuild9
1 files changed, 8 insertions, 1 deletions
diff --git a/games-strategy/julius/julius-1.4.1.ebuild b/games-strategy/julius/julius-1.4.1.ebuild
index 06b33f139f83..811dfaebf3f6 100644
--- a/games-strategy/julius/julius-1.4.1.ebuild
+++ b/games-strategy/julius/julius-1.4.1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit cmake
+inherit cmake xdg
DESCRIPTION="Feature-faithful open source re-implementation of Caesar III"
HOMEPAGE="https://github.com/bvschaik/julius"
@@ -20,6 +20,11 @@ DEPEND="
"
RDEPEND="${DEPEND}"
+src_prepare() {
+ cmake_src_prepare
+ xdg_src_prepare
+}
+
src_install() {
insinto /etc/profile.d
doins "${FILESDIR}"/90julius.sh
@@ -29,6 +34,8 @@ src_install() {
}
pkg_postinst() {
+ xdg_pkg_postinst
+
ewarn "Julius requires you to download the original Caesar 3 resources."
ewarn
ewarn "You need to obtain these files from a vendor of the proprietary software."