summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2018-05-02 20:03:10 +0200
committerPacho Ramos <pacho@gentoo.org>2018-05-02 21:27:52 +0200
commit6a75659b72ad7b71fa16e7ee07fa3a5fecd978b5 (patch)
treeca69840b26c34a330f0ff74fdf49e46cace64fcd /games-strategy/lightyears
parentgames-strategy/lgeneral: Drop old (diff)
downloadgentoo-6a75659b72ad7b71fa16e7ee07fa3a5fecd978b5.tar.gz
gentoo-6a75659b72ad7b71fa16e7ee07fa3a5fecd978b5.tar.bz2
gentoo-6a75659b72ad7b71fa16e7ee07fa3a5fecd978b5.zip
games-strategy/lightyears: Stop using games.eclass
Package-Manager: Portage-2.3.31, Repoman-2.3.9
Diffstat (limited to 'games-strategy/lightyears')
-rw-r--r--games-strategy/lightyears/files/lightyears-1.4-gentoo.patch4
-rw-r--r--games-strategy/lightyears/lightyears-1.4-r2.ebuild50
2 files changed, 52 insertions, 2 deletions
diff --git a/games-strategy/lightyears/files/lightyears-1.4-gentoo.patch b/games-strategy/lightyears/files/lightyears-1.4-gentoo.patch
index 063dbab3c1e8..325c4365ded4 100644
--- a/games-strategy/lightyears/files/lightyears-1.4-gentoo.patch
+++ b/games-strategy/lightyears/files/lightyears-1.4-gentoo.patch
@@ -1,5 +1,5 @@
---- lightyears
-+++ lightyears
+--- a/lightyears
++++ b/lightyears
@@ -1,7 +1,6 @@
#!/usr/bin/python
diff --git a/games-strategy/lightyears/lightyears-1.4-r2.ebuild b/games-strategy/lightyears/lightyears-1.4-r2.ebuild
new file mode 100644
index 000000000000..7e7344951fc2
--- /dev/null
+++ b/games-strategy/lightyears/lightyears-1.4-r2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+inherit desktop python-single-r1
+
+DESCRIPTION="A single-player game with a science-fiction theme"
+HOMEPAGE="http://www.jwhitham.org/20kly/"
+SRC_URI="http://www.jwhitham.org/20kly/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE=""
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+RDEPEND="${PYTHON_DEPS}
+ dev-python/pygame[${PYTHON_USEDEP}]
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+ eapply "${FILESDIR}/${P}"-gentoo.patch
+ sed -i \
+ -e "s:@GENTOO_LIBDIR@:/usr/$(get_libdir)/${PN}:" \
+ -e "s:@GENTOO_DATADIR@:/usr/share/${PN}:" \
+ ${PN} || die
+ python_fix_shebang .
+}
+
+src_install() {
+ dobin ${PN}
+
+ insinto /usr/"$(get_libdir)/${PN}"
+ doins code/*.py
+
+ einstalldocs
+
+ insinto "/usr/share/${PN}"
+ doins -r audio data manual
+
+ python_optimize "${ED}/usr/$(get_libdir)/${PN}"
+
+ newicon data/32.png ${PN}.png
+ make_desktop_entry ${PN} "Light Years Into Space"
+}