summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-strategy/scorched3d/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-strategy/scorched3d/files')
-rw-r--r--games-strategy/scorched3d/files/scorched3d-44-fixups.patch25
-rw-r--r--games-strategy/scorched3d/files/scorched3d-44-freetype.patch45
-rw-r--r--games-strategy/scorched3d/files/scorched3d-44-gcc43.patch22
-rw-r--r--games-strategy/scorched3d/files/scorched3d-44-jpeg9.patch20
-rw-r--r--games-strategy/scorched3d/files/scorched3d-44-odbc.patch16
-rw-r--r--games-strategy/scorched3d/files/scorched3d-44-win32.patch18
6 files changed, 146 insertions, 0 deletions
diff --git a/games-strategy/scorched3d/files/scorched3d-44-fixups.patch b/games-strategy/scorched3d/files/scorched3d-44-fixups.patch
new file mode 100644
index 000000000000..47499d4cf307
--- /dev/null
+++ b/games-strategy/scorched3d/files/scorched3d-44-fixups.patch
@@ -0,0 +1,25 @@
+--- scorched.orig/configure.ac
++++ scorched/configure.ac
+@@ -13,22 +13,6 @@
+ AC_PROG_INSTALL
+ AC_PROG_RANLIB
+
+-LDFLAGS="$LDFLAGS -L/usr/X11R6/lib -L/usr/X11R6"
+-CPPFLAGS="$CPPFLAGS -I/usr/X11R6/include -I/usr/X11R6"
+-
+-if test `uname` == Darwin; then
+-LDFLAGS="$LDFLAGS -lmx"
+-CPPFLAGS="$CPPFLAGS -DFFTW_USE_DOUBLE -D__DARWIN__ -D__MACOSX__"
+-else
+-LDFLAGS="$LDFLAGS -L/usr/local/lib"
+-CPPFLAGS="$CPPFLAGS -I/usr/local/include"
+-fi
+-
+-AC_CHECK_LIB(fridge, beer, echo "Hmm?!",[
+- echo "Warning: No beer found in fridge!";
+- echo "We highly suggest that you rectify this situation immediately."
+-])
+-
+ AC_ARG_ENABLE(serveronly,
+ [ --enable-serveronly Enable server only compilation],
+ , enable_serveronly=no,
diff --git a/games-strategy/scorched3d/files/scorched3d-44-freetype.patch b/games-strategy/scorched3d/files/scorched3d-44-freetype.patch
new file mode 100644
index 000000000000..93c8ca358b31
--- /dev/null
+++ b/games-strategy/scorched3d/files/scorched3d-44-freetype.patch
@@ -0,0 +1,45 @@
+--- acinclude.m4.orig
++++ acinclude.m4
+@@ -437,7 +437,7 @@
+ if test "$FT2_CONFIG" = "no" ; then
+ no_ft=yes
+ else
+- FT2_CFLAGS=`$FT2_CONFIG $ft_config_args --cflags`
++ FT2_CFLAGS="`$FT2_CONFIG $ft_config_args --cflags` `$FT2_CONFIG $ft_config_args --cflags | sed -e 's:freetype2:freetype2/freetype:'`"
+ FT2_LIBS=`$FT2_CONFIG $ft_config_args --libs`
+ ft_config_major_version=`$FT2_CONFIG $ft_config_args --version | \
+ sed 's/\([[0-9]]*\).\([[0-9]]*\).\([[0-9]]*\)/\1/'`
+--- src.orig/client/GLEXT/GLFont2dFreeType.h
++++ src/client/GLEXT/GLFont2dFreeType.h
+@@ -23,10 +23,10 @@
+
+ #include <GLEXT/GLFont2dStorage.h>
+ #include <ft2build.h>
+-#include <freetype/freetype.h>
+-#include <freetype/ftglyph.h>
+-#include <freetype/ftoutln.h>
+-#include <freetype/fttrigon.h>
++#include <freetype.h>
++#include <ftglyph.h>
++#include <ftoutln.h>
++#include <fttrigon.h>
+ #include <string>
+
+ class GLFont2dFreeType
+--- src.orig/launcher/wxdialogs/TrueTypeFont.h
++++ src/launcher/wxdialogs/TrueTypeFont.h
+@@ -25,10 +25,10 @@
+ #include <wx/image.h>
+ #include <ft2build.h>
+ #include <string>
+-#include <freetype/freetype.h>
+-#include <freetype/ftglyph.h>
+-#include <freetype/ftoutln.h>
+-#include <freetype/fttrigon.h>
++#include <freetype.h>
++#include <ftglyph.h>
++#include <ftoutln.h>
++#include <fttrigon.h>
+
+ class TrueTypeFont
+ {
diff --git a/games-strategy/scorched3d/files/scorched3d-44-gcc43.patch b/games-strategy/scorched3d/files/scorched3d-44-gcc43.patch
new file mode 100644
index 000000000000..79f40b70e652
--- /dev/null
+++ b/games-strategy/scorched3d/files/scorched3d-44-gcc43.patch
@@ -0,0 +1,22 @@
+--- scorched.old/src/common/common/main.h
++++ scorched/src/common/common/main.h
+@@ -40,7 +40,7 @@
+ void _no_storage()
+ {
+ printf("Failed to allocate memory!!");
+- std::exit(1);
++ exit(1);
+ }
+
+ void run_main(int argc, char *argv[], OptionsParameters &params)
+--- scorched.old/src/common/porting/windows.h
++++ scorched/src/common/porting/windows.h
+@@ -20,7 +20,7 @@
+ typedef unsigned short WORD;
+ typedef unsigned char BYTE;
+
+-typedef int HWND;
++// typedef int HWND;
+ typedef void * HINSTANCE;
+ typedef int WPARAM;
+ typedef int LPARAM;
diff --git a/games-strategy/scorched3d/files/scorched3d-44-jpeg9.patch b/games-strategy/scorched3d/files/scorched3d-44-jpeg9.patch
new file mode 100644
index 000000000000..8255dd33f5d3
--- /dev/null
+++ b/games-strategy/scorched3d/files/scorched3d-44-jpeg9.patch
@@ -0,0 +1,20 @@
+--- src/common/image/ImageJpgFactory.cpp.old 2014-12-03 09:52:03.306552513 +0100
++++ src/common/image/ImageJpgFactory.cpp 2014-12-03 09:53:22.117786304 +0100
+@@ -79,7 +79,7 @@
+ src->next_input_byte = FakeEOI;
+ src->bytes_in_buffer = 2;
+
+- return TRUE;
++ return (boolean)TRUE;
+ }
+
+ METHODDEF(void)
+@@ -166,7 +166,7 @@
+ src->bytes_in_buffer = buffer.getBufferUsed();
+ src->next_input_byte = (JOCTET *) buffer.getBuffer();
+
+- jpeg_read_header(&cinfo, TRUE);
++ jpeg_read_header(&cinfo, (boolean)TRUE);
+ jpeg_start_decompress(&cinfo);
+
+ if ((cinfo.output_components == 3 && !readalpha) ||
diff --git a/games-strategy/scorched3d/files/scorched3d-44-odbc.patch b/games-strategy/scorched3d/files/scorched3d-44-odbc.patch
new file mode 100644
index 000000000000..e7f3833bf897
--- /dev/null
+++ b/games-strategy/scorched3d/files/scorched3d-44-odbc.patch
@@ -0,0 +1,16 @@
+When x11-libs/wxGTK is built with the odbc use flag, scorched3d fails to build.
+bug #285384 - patch from Bob Johnson
+
+--- scorched/src/common/porting/windows.h
++++ fix_scorched/src/common/porting/windows.h
+@@ -11,8 +11,8 @@
+
+ typedef char * LPSTR;
+ typedef const char * LPCTSTR;
+-typedef unsigned int DWORD;
+-typedef unsigned int * LPDWORD;
++typedef unsigned long DWORD;
++typedef DWORD * LPDWORD;
+ typedef unsigned char * LPBYTE;
+ typedef int INT;
+ typedef long LONG;
diff --git a/games-strategy/scorched3d/files/scorched3d-44-win32.patch b/games-strategy/scorched3d/files/scorched3d-44-win32.patch
new file mode 100644
index 000000000000..05f9c806b1c7
--- /dev/null
+++ b/games-strategy/scorched3d/files/scorched3d-44-win32.patch
@@ -0,0 +1,18 @@
+--- scorched.old/src/common/porting/windows.h
++++ scorched/src/common/porting/windows.h
+@@ -9,6 +9,7 @@
+ #include <ctype.h>
+ #include <common/Defines.h>
+
++#ifdef _WIN32
+ typedef char * LPSTR;
+ typedef const char * LPCTSTR;
+ typedef unsigned int DWORD;
+@@ -27,6 +28,7 @@
+ typedef int LRESULT;
+ typedef void * HDC;
+ typedef void * HGLRC;
++#endif /* _WIN32 */
+
+ #define _strnicmp(a,b,c) strncasecmp(a,b,c)
+ #define stricmp(a,b) strcasecmp(a,b)